Package Details: pybgsetter 0.50.2.g4fdeb33-1

Git Clone URL: https://aur.archlinux.org/pybgsetter.git (read-only)
Package Base: pybgsetter
Description: Multi-backend GUI/CLI tool to set the desktop wallpaper.
Upstream URL: http://bbs.archlinux.org/viewtopic.php?id=88997
Licenses: GPL
Submitter: None
Maintainer: haawda
Last Packager: Alad
Votes: 12
Popularity: 0.004726
First Submitted: 2010-01-17 01:46
Last Updated: 2015-08-19 23:33

Dependencies (7)

Required by (0)

Sources (1)

Latest Comments

Alad commented on 2015-08-19 23:34

Updated, cheers.

haawda commented on 2015-08-19 23:09

I added a tag to the git repo, so
pkgver() {
cd "$srcdir"/$_gitname
git describe --tags | sed 's+-+.+g'
}
would automatically generate a version number.

haawda commented on 2015-08-19 18:06

I merged your pull request, thanks .

Alad commented on 2015-08-18 20:57

Updated to use the github repo.

cokomoko commented on 2015-08-09 22:56

I solved the problem

I have edited the PKGBUILD file as follows:

# Maintainer: Alad Wenter <https://wiki.archlinux.org/index.php/Special:EmailUser/Alad>
# Contributor: Pável Varela Rodríguez [NeOnsKuLL] <neonskull@gmail.com>

pkgname=pybgsetter
pkgver=0.5
pkgrel=3

pkgdesc="Multi-backend (hsetroot, Esetroot, habak, feh) User Friendly GUI/CLI tool to set desktop wallpaper"
url="http://bbs.archlinux.org/viewtopic.php?id=88997"
arch=('any')
license=('GPL')
install=pybgsetter.install
optdepends=('hsetroot: to activate support for Hsetroot' \
'esetroot: to activate support for Esetroot' \
'habak: to activate support for Habak' \
'feh: to activate support for Feh')
source=($pkgname-$pkgver.tar.bz2 pybgsetter.install)
sha256sums=('7b430784ce0e7f3d7508ac2bcba2b422252270de82c913294628bb4c110cbc4b'
'66a4588c6143d5df993ff917e4489e13d0d5e3eb99b54f38d999e842adb3a688')


package() {
cd $srcdir/$pkgname-$pkgver
./install.sh $pkgdir/
}

no problem


makepkg -csi
==> pybgsetter 0.5-3 (Paz Ağu 9 22:48:35 UTC 2015) paketi oluşturuluyor
==> Bağımlılıklar denetleniyor...
==> Derleme bağımlılıkları denetleniyor...
==> Kaynaklar getiriliyor...
-> pybgsetter-0.5.tar.bz2 bulundu
-> pybgsetter.install bulundu
==> Kaynak dosyaları sha256sums ile doğrulanıyor...
pybgsetter-0.5.tar.bz2 ... Doğrulandı
pybgsetter.install ... Doğrulandı
==> Kaynaklar açılıyor...
-> pybgsetter-0.5.tar.bz2 ile bsdtar açılıyor
==> Mevcut $pkgdir/ dizini kaldırılıyor ...
==> fakeroot ortamına giriliyor...
==> package() işlemine başlanıyor...
==> Kurulum düzenleniyor...
-> İstenmeyen dosyalar kaldırılıyor...
-> libtool dosyaları kaldırılıyor...
-> Statik kütüphane dosyaları kaldırılıyor...
-> Kılavuz ve bilgi sayfaları sıkıştırılıyor...
-> İkilik dosyalardan ve kütüphanelerden gereksiz ayıklama sembolleri ayıklanıyor...
==> "pybgsetter" paketi oluşturuluyor...
-> .PKGINFO dosyası üretiliyor...
-> install dosyası ekleniyor...
-> .MTREE dosyası oluşturuluyor...
-> Paket sıkıştırılıyor...
==> fakeroot ortamından çıkılıyor.
==> pybgsetter 0.5-3 (Paz Ağu 9 22:48:36 UTC 2015) paketinin derlenmesi tamamlandı
==> pybgsetter paketi pacman -U ile kuruluyor ...
[sudo] password for cokomoko:

cokomoko commented on 2015-08-09 22:54

I solved the problem

I have edited the data file as follows:

# Maintainer: Alad Wenter <https://wiki.archlinux.org/index.php/Special:EmailUser/Alad>
# Contributor: Pável Varela Rodríguez [NeOnsKuLL] <neonskull@gmail.com>

pkgname=pybgsetter
pkgver=0.5
pkgrel=3

pkgdesc="Multi-backend (hsetroot, Esetroot, habak, feh) User Friendly GUI/CLI tool to set desktop wallpaper"
url="http://bbs.archlinux.org/viewtopic.php?id=88997"
arch=('any')
license=('GPL')
install=pybgsetter.install
optdepends=('hsetroot: to activate support for Hsetroot' \
'esetroot: to activate support for Esetroot' \
'habak: to activate support for Habak' \
'feh: to activate support for Feh')
source=($pkgname-$pkgver.tar.bz2 pybgsetter.install)
sha256sums=('7b430784ce0e7f3d7508ac2bcba2b422252270de82c913294628bb4c110cbc4b'
'66a4588c6143d5df993ff917e4489e13d0d5e3eb99b54f38d999e842adb3a688')


package() {
cd $srcdir/$pkgname-$pkgver
./install.sh $pkgdir/
}

no problem


makepkg -csi
==> pybgsetter 0.5-3 (Paz Ağu 9 22:48:35 UTC 2015) paketi oluşturuluyor
==> Bağımlılıklar denetleniyor...
==> Derleme bağımlılıkları denetleniyor...
==> Kaynaklar getiriliyor...
-> pybgsetter-0.5.tar.bz2 bulundu
-> pybgsetter.install bulundu
==> Kaynak dosyaları sha256sums ile doğrulanıyor...
pybgsetter-0.5.tar.bz2 ... Doğrulandı
pybgsetter.install ... Doğrulandı
==> Kaynaklar açılıyor...
-> pybgsetter-0.5.tar.bz2 ile bsdtar açılıyor
==> Mevcut $pkgdir/ dizini kaldırılıyor ...
==> fakeroot ortamına giriliyor...
==> package() işlemine başlanıyor...
==> Kurulum düzenleniyor...
-> İstenmeyen dosyalar kaldırılıyor...
-> libtool dosyaları kaldırılıyor...
-> Statik kütüphane dosyaları kaldırılıyor...
-> Kılavuz ve bilgi sayfaları sıkıştırılıyor...
-> İkilik dosyalardan ve kütüphanelerden gereksiz ayıklama sembolleri ayıklanıyor...
==> "pybgsetter" paketi oluşturuluyor...
-> .PKGINFO dosyası üretiliyor...
-> install dosyası ekleniyor...
-> .MTREE dosyası oluşturuluyor...
-> Paket sıkıştırılıyor...
==> fakeroot ortamından çıkılıyor.
==> pybgsetter 0.5-3 (Paz Ağu 9 22:48:36 UTC 2015) paketinin derlenmesi tamamlandı
==> pybgsetter paketi pacman -U ile kuruluyor ...
[sudo] password for cokomoko:

cokomoko commented on 2015-08-09 22:33

==> pybgsetter will get built? [E / h]
==> ----------------------------------
==>
==> Packet built whether loading
==> pybgsetter is 0.5-3 (Mon Aug 9 10:39:40 UTC 2015) Creating package
==> Checking dependencies ...
==> Checking compile dependencies ...
==> Resources brought ...
-> pybgsetter-0.5.tar.bz2 is found
==> ERROR: Integrity checks (SHA256) does not match the size of the files in the source array.
==> ERROR: makepkg pybgsetter was not built.
==> pybgsetter will get rebuilt? [Y / N]
==> ------------------------------------------
==>

Alad commented on 2015-08-09 16:13

Neat, I'll update the sources.

haawda commented on 2015-08-09 11:24

cokomoko: can you please set LANG=C to get english error messages and repeat your question? You will more probably get answers.

BTW, I opend a github repo for pybgsetter, though I am not the author. See the forum discussion for a link.

haawda commented on 2015-08-09 11:23

cokomoko: can you please set LANG=C to get english error messages and repeat your question? You will more probably get answers.

BTW, I opend a github repo for pybgsetter, though I am not the author.

cokomoko commented on 2015-08-09 10:40

==> pybgsetter inşa edilsin mi ? [E/h]
==> ----------------------------------
==>
==> Paket inşa edilip yükneniyor
==> pybgsetter 0.5-3 (Paz Ağu 9 10:39:40 UTC 2015) paketi oluşturuluyor
==> Bağımlılıklar denetleniyor...
==> Derleme bağımlılıkları denetleniyor...
==> Kaynaklar getiriliyor...
-> pybgsetter-0.5.tar.bz2 bulundu
==> HATA: Bütünlük kontrolleri (sha256) kaynak dizisindeki dosyaların boyutlarıyla örtüşmüyor.
==> HATA:makepkg pybgsetter'i inşa edemedi.
==> pybgsetter yeniden inşa edilsin mi ? [e/H]
==> ------------------------------------------
==>

Anonymous comment on 2011-11-14 14:12

It's been a long time since last update, sorry, I was really busy.

All problems solved, just 2 problems with Exceptions definition and defining python2 as interpreter. Any kind of feedback accepted, ;-)

See you

Anonymous comment on 2010-12-06 19:22

I am a robot. This is not an official message. AUR guidelines suggest to not include binaries. Examples:
pybgsetter/pybgsetter-0.3.2.tar.bz2
Feel free to disregard this as you would any other comment. This robot will not post here again.