Package Details: pycharm-community-eap 9:2021.1.211.6085.15-1

Git Clone URL: https://aur.archlinux.org/pycharm-community-eap.git (read-only, click to copy)
Package Base: pycharm-community-eap
Description: Powerful Python and Django IDE, Early Access Program (EAP) build, Community Edition
Upstream URL: http://www.jetbrains.com/pycharm
Keywords: development early-access editor ide jetbrains python
Licenses: Apache
Conflicts: pycharm-community-edition
Provides: pycharm-community-edition
Submitter: flying-sheep
Maintainer: Kr1ss
Last Packager: Kr1ss
Votes: 13
Popularity: 0.026927
First Submitted: 2015-10-03 13:11
Last Updated: 2021-02-19 18:33

Pinned Comments

Kr1ss commented on 2020-08-27 14:20

The mandatory make dependency to python2-setuptools has been removed. If you want to have a precompiled Python 2 debugger included with the package, please make sure that python2-setuptools is installed before building pycharm-community-eap.

It won't be auto-installed and/or -removed any more by makepkg -sr.

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

alt0160 commented on 2018-10-22 17:23

Can you add libdbusmenu-glib as a dependency?

Without it, PyCharm doesn't start: 'java.lang.UnsatisfiedLinkError: /opt/pycharm-community-eap/bin/libdbm64.so: libdbusmenu-glib.so.4: cannot open shared object file: No such file or directory'

Also reported here

Kr1ss commented on 2018-09-05 19:43

Great, thx for ur trust ! And here comes an update... :D

flying-sheep commented on 2018-09-02 14:55

Hi, thank you!

I’m updating it while writing this. Also I added you as co-maintainer.

Kr1ss commented on 2018-06-16 17:04

I updated the build files to the current EAP version, which is 2018.2.1 (Build 182.3911.3) atm. Note that I had to introduce an epoch number because otherwise the newly added sub version number would confuse pacman's version sorting: 2018.2.182.3684.83-1 > 2018.2.1.3911.3-1

U can pull that if u like @flying-sheep : https://gitlab.com/Kr1ss/AUR_PyCharm-CE-EAP.git

EDIT - Thx for the update !

EDIT2 - Upstream has pushed some more updates in the meantime. Current build is 182.4323.5, which is 2018.2.3RC; have updated the GitLab repo.

notuxius commented on 2016-09-14 19:35

A small fix - Professional edition in description but this is Community edition

tovo commented on 2016-08-11 08:08

Thanks mate,
It works when you run it twice.

flying-sheep commented on 2016-08-08 15:39

you have to run makepkg twice, sorry about that (the sha-extracting expression in the pkgbuild is evaluated before the file containing the hash is downloaded)

tovo commented on 2016-08-08 15:28

Hi there,
I'm unable to upgrade my pycharm-community due to a failed integrity check :
==> ERROR: Integrity checks (sha256) differ in size from the source array.
==> ERROR: Makepkg was unable to build pycharm-community-eap.
==> Restart building pycharm-community-eap ? [y/N]
==> ----------------------------------------------
==>

==> ERROR: unable to update
I'm a alone ?
Cheers

flying-sheep commented on 2016-01-31 22:16

well, pycharm-community is now at 5.0.4, so why use this?

i’ll probably update this once it’s a preview for pycharm 6.

but if you want you can take over, too!

gabor_bernat commented on 2016-01-25 10:01

Is this still on?