Package Details: pygobject-devel-patched 3.26.0-1

Git Clone URL: https://aur.archlinux.org/pygobject-patched.git (read-only)
Package Base: pygobject-patched
Description: Common development files for pygobject
Upstream URL: https://wiki.gnome.org/Projects/PyGObject
Keywords: gobject pygobject python
Licenses: LGPL
Conflicts: pygobject-devel
Provides: pygobject-devel=3.26.0
Submitter: wangjiezhe
Maintainer: wangjiezhe
Last Packager: wangjiezhe
Votes: 3
Popularity: 0.473311
First Submitted: 2015-07-22 08:31
Last Updated: 2017-10-10 05:47

Required by (15)

Sources (1)

Latest Comments

wangjiezhe commented on 2017-10-10 05:40

The bug with cairo has been fixed in version 3.26.0, so this package is not needed now. Please use the offical package instead.

ebs007 commented on 2016-07-22 18:29

Please, fix the dependence to new version of pygobject-devel to ^3.20.1 or 3.21.0.

freundTech commented on 2016-06-02 07:15

This package doesn't build on my system. Does anyone else have the same problem?

../../pygobject-3.20.0/gi/pygi-foreign-cairo.c:382:17: error: 'PycairoRegion' undeclared (first use in this function)
region = ( (PycairoRegion*) value)->region;

EDIT: I found the Problem. The python-cairo package doesn't include PycairoRegion. You have to install python-cairo-git.
If the dependencie on python-cairo gets changed to python-cairo-git the package should work.

wangjiezhe commented on 2015-07-22 12:51

Fix bug in https://bugzilla.gnome.org/show_bug.cgi?id=667959