Package Details: pyjama 0.3.1-2

Git Clone URL: (read-only)
Package Base: pyjama
Description: Unofficial Python/GTK Medialibrary for Jamendo
Upstream URL:
Keywords: Jamendo Medialibrary
Licenses: GPL
Submitter: reztho
Maintainer: None
Last Packager: ValHue
Votes: 32
Popularity: 0.000000
First Submitted: 2008-10-18 22:59
Last Updated: 2016-09-12 17:37

Latest Comments

ValHue commented on 2016-09-18 09:31

Jamendo no longer uses the same API that's used to create Pyjama - Nögel Daniel. More information (Old (deprecated) Api)

For that reason not download the database, or the images of the albumns or anything.

I'll leave this package and I'll find a new client of Jamendo.

Thank you

nimrod_mack commented on 2016-09-13 06:20

Thank you :) Building the package now works for me :) However I only managed to run it after installing `gstreamer0.10-good` and `gstreamer0.10-good-plugins`. Also I needed to fix a little bug in `modules/` line 198 (it was "pulseaudio" there, but the required sink is named "pulsesink").
So then it started. But I couldn't play any music. I inspected the created traffic and the program only tried to connect to Daniel Nögel's server to download some kind of jamendo database. It failed doing so and kept reporting errors on and on. I've no clue how to fix this problem.

ValHue commented on 2016-09-12 17:33

I think I've found a solution. I hope your comments.

ValHue commented on 2016-09-12 16:41

I'm sorry, but I can not do anything about it. The author, for some unknown reason has removed from its website the download link. I'll stay a while waiting to see if re-offer and if not, the only possible, it would downgrade the package with an earlier version of which are still in Launchpad

nimrod_mack commented on 2016-09-12 13:44

The link to the source just gives me a few redirects before returning some HTML... I couldn't find the sources of the current version anywhere else.

ValHue commented on 2015-10-02 08:29

PyXML is outdated, replace it python2-lxml and works perfectly.

Cravix commented on 2015-09-15 03:15

Since dependency package "pyxml" is missing now (vanished(?) AUR package), and I haven't use this as well, I decide to disown this one,
feel free to pick it up, and don't forget to upload pyxml PKGBUILD to AUR as well :)
(P.S. the author of pyjama also provides some experimental version of pyjama at http://nö , but I've never checked that, you can try it too~

Cravix commented on 2013-05-26 07:08

ok, i'll take this pack... and seems the development stopped, eh.

reztho commented on 2013-05-22 14:13

Cravix, I disown this package since I see the software is somewhat abandoned and I'm not really interested in it anymore. Feel free to own it and update it.

Cravix commented on 2013-05-22 11:53

eh, i just adjust the PKGBUILD (not only change for, you can have a look:

Cravix commented on 2013-05-22 11:38

and, there're lots of backup files (which has "~" in their file name i think), so don't forget add

find . -name "*~*" -exec rm {} \;

after cd to source folder...

Cravix commented on 2013-05-22 11:33

it's here, fetched from /usr/share/apps/pyjama/plugins/PVC/ ...

Cravix commented on 2013-05-22 11:33

it's here, fetched from /usr/share/apps/pyjama/plugins/PVC/ ...

reztho commented on 2013-05-19 18:03

Cravix, where is the announcement page for that version? Pyjama's still at version in Launchpad.

Cravix commented on 2013-05-19 12:00

and there's a newer version of pyjama...

Cravix commented on 2013-05-09 04:05

please add gstreamer0.10-ugly-plugins as deps, thanks!

reztho commented on 2012-10-19 09:43

Fixed. Thx, nodevel.

nodevel commented on 2012-10-19 07:26

python-pysqlite and python-simplejson have been renamed to python2-pysqlite, python2-simplejson respectively. Please fix the dependencies accordingly. Thank you.

reztho commented on 2010-11-01 16:29

Fixed. Thx, gabrielcossette.

Anonymous comment on 2010-10-24 05:45

Pyjama isn't currently compatible with Python 3.

In order to make it work, I had to change the first line of /usr/bin/pyjama to
#!/usr/bin/env python2

reztho commented on 2010-08-15 11:36

Gnome-python-extras is needed for the embedded mozilla firefox plugin at least, but certainly it's not required. Python-notify is optional too. So I added them to the optional dependencies of the PKGBUILD.

dcelasun commented on 2010-08-12 09:59

Uhm... gnome-python and gnome-python-extras are NOT required by pyjama.

See here:

Can you remove those deps please?