Package Details: pyqglviewer 0.11-4

Git Clone URL: https://aur.archlinux.org/pyqglviewer.git (read-only)
Package Base: pyqglviewer
Description: Python binding for libQGLViewer C++ library
Upstream URL: http://pyqglviewer.gforge.inria.fr/wiki/doku.php
Licenses: GPL2, custom, GPL3
Submitter: gian
Maintainer: gian
Last Packager: gian
Votes: 0
Popularity: 0.000000
First Submitted: 2011-03-10 22:46
Last Updated: 2015-06-08 19:52

Latest Comments

gian commented on 2013-07-14 21:49

Alister,

probably you are right, but I'd like to avoid to have pyqglviewer to conflict with libqglviewer since I need both of them installed.

As far as I know, at least for now, the library from the python package is compatible with the upstream release. I will look into the matter anyway

bye
Gianluca

Alister.Hood commented on 2013-07-03 16:13

Hi, I still think it needs to conflict with libqglviewer.

gian commented on 2013-07-01 07:13

Hi Alister,

I will look into the matter and I will add the line you suggest.
Thanks

Alister.Hood commented on 2013-06-30 14:47

Oh, I disabled threading by commenting out the MAKEFLAGS line, and disabled ccache, and then it build OK. I guess it needs this line added (like libqglviewer):

options=(!makeflags)

Alister.Hood commented on 2013-06-30 09:53

It currently fails for me fails like this - does anyone have a clue?:

g++ -Wl,-O1,--sort-common,--as-needed,-z,relro -Wl,-O1 -shared -o libqglviewerplugin.so .obj/qglviewerPlugin.Qt4.o .obj/moc_qglviewerPlugin.Qt4.o -L/usr/X11R6/lib -L/usr/lib -L/usr/lib/qt4/plugins/lib -lQGLViewer -lpthread -lGL -lGLU -lQtXml -lQtOpenGL -lQtGui -lQtCore -lQtDesigner
/usr/bin/ld: cannot find -lQGLViewer
collect2: error: ld returned 1 exit status
make[1]: *** [libqglviewerplugin.so] Error 1
make[1]: Leaving directory `/tmp/yaourt-tmp-root/aur-pyqglviewer/src/libQGLViewer-2.3.17-py/designerPlugin'
make: *** [sub-designerPlugin-install_subtargets-ordered] Error 2

Alister.Hood commented on 2013-06-30 09:50

It currently fails for me fails like this - does anyone have a clue?:

g++ -Wl,-O1,--sort-common,--as-needed,-z,relro -Wl,-O1 -shared -o libqglviewerplugin.so .obj/qglviewerPlugin.Qt4.o .obj/moc_qglviewerPlugin.Qt4.o -L/usr/X11R6/lib -L/usr/lib -L/usr/lib/qt4/plugins/lib -lQGLViewer -lpthread -lGL -lGLU -lQtXml -lQtOpenGL -lQtGui -lQtCore -lQtDesigner
/usr/bin/ld: cannot find -lQGLViewer
collect2: error: ld returned 1 exit status
make[1]: *** [libqglviewerplugin.so] Error 1
make[1]: Leaving directory `/tmp/yaourt-tmp-root/aur-pyqglviewer/src/libQGLViewer-2.3.17-py/designerPlugin'
make: *** [sub-designerPlugin-install_subtargets-ordered] Error 2

foxcub commented on 2013-03-01 21:43

qt needs to become qt4

Alister.Hood commented on 2012-06-30 04:55

But it needs to say that it conflicts with libqglviewer

Alister.Hood commented on 2012-06-30 04:10

Thanks, it works now

gian commented on 2012-03-18 23:39

Thanks for the comment.
I am sorry, but it does not work at the moment, I am working to resolve the issue.

All comments