Package Details: pyside6-tools-wrappers 20230711-1

Git Clone URL: https://aur.archlinux.org/pyside6-tools-wrappers.git (read-only, click to copy)
Package Base: pyside6-tools-wrappers
Description: Provides pyside6-* executables (such as pyside6-rcc and pyside6-uic)
Upstream URL: https://code.qt.io/cgit/pyside/pyside-setup.git/tree/sources/pyside-tools/pyside_tool.py
Licenses: LGPL3
Submitter: yibe
Maintainer: yibe
Last Packager: yibe
Votes: 3
Popularity: 0.154730
First Submitted: 2023-05-28 02:44 (UTC)
Last Updated: 2023-07-11 17:54 (UTC)

Dependencies (5)

Required by (1)

Sources (1)

Latest Comments

krobe commented on 2023-07-12 00:48 (UTC)

Conflicting files issue is resolved, thanks!

yibe commented on 2023-07-11 18:04 (UTC)

@krobe Updated the PKGBUILD. To resolve the conflict, please uninstall this package, upgrade pyside6-tools to the latest version, and then rebuild the package.

krobe commented on 2023-07-10 12:32 (UTC) (edited on 2023-07-10 14:44 (UTC) by krobe)

Regarding use of rcc with -g, please try running rcc with the -g option and take a look at the import at the top of the output file. It will show 'from PySide2 import QtCore' which would not be compatible with PySide6. This package is useful but now there appears to be a conflict with the pyside6-tools package:

Checking file conflicts... Failed to commit transaction: conflicting files: - pyside6-tools: /usr/bin/pyside6-designer already exists in filesystem (owned by pyside6-tools-wrappers)

Fuzzy commented on 2023-07-05 15:19 (UTC) (edited on 2023-07-05 15:20 (UTC) by Fuzzy)

pyside6-rcc and pyside6-uic are actually not needed as you have to use normal rcc and uic with -g option. So I'm not sure that this package is useful.

krobe commented on 2023-05-28 15:59 (UTC)

Helpful package, thanks!