Package Details: python-agate-sql 0.5.8-1

Git Clone URL: https://aur.archlinux.org/python-agate-sql.git (read-only, click to copy)
Package Base: python-agate-sql
Description: Adds SQL read/write support to agate
Upstream URL: https://agate-sql.readthedocs.org
Licenses: MIT
Submitter: alerque
Maintainer: alerque
Last Packager: alerque
Votes: 1
Popularity: 0.106299
First Submitted: 2021-06-22 19:59
Last Updated: 2021-09-15 22:40

Latest Comments

alerque commented on 2021-07-27 08:19

@ArchVie Yes there is a problem, but the problem is upstream. Their test suite does not work on the newer version of parsedatetime. That dependency is only required to run the check function, so you can avoid the issue by building without checks (makepkg --nocheck) so that the checkepends become unnecessary. In fact I've set this as the default by disabling checks by default (see comments at the top of the PKGBUILD) in a way that makepkg will understand. Not all AUR helpers will catch on to this however, some will parse it and find the checkdepends without looking to see whether they are actually doing to run the checks or not.

Unfortunately I think the actual issues is in some library used by agate-sql. I ran out of time to trace down where it actually was. If you want to contribute I'm sure tracking that down and submitting a fix so the test suite works on the latest versions of things would be much appreciated.

ArchVie commented on 2021-07-26 19:36

There seems to be a problem with dependencies since python-agate-sql 0.5.7 depends on python-parsedatetime<=2.5 and the actual installed version on a recent Arch Linux system is 2.6.3. I did not try to compile it with recent python-parsdatetime yet.