Package Details: python-aplpy 1.0-1

Git Clone URL: (read-only)
Package Base: python-aplpy
Description: An astronomical plotting library in python
Upstream URL:
Licenses: MIT
Submitter: mboquien
Maintainer: mboquien
Last Packager: mboquien
Votes: 4
Popularity: 0.000000
First Submitted: 2010-07-08 13:51
Last Updated: 2015-06-21 07:48

Latest Comments

mboquien commented on 2015-01-27 22:01

And the packages have been updated.

migueldvb commented on 2015-01-27 21:42

APLpy 0.9.14 is released

mboquien commented on 2014-10-30 23:13

Thanks for pointing this out. I have made a new release.

migueldvb commented on 2014-10-30 21:21

The dependency on python-imaging should be replaced by python-pillow

migueldvb commented on 2014-09-24 21:46

aplpy 0.9.12 is released:

mboquien commented on 2013-04-25 20:52


I have updated the package to 0.9.9. Be aware of a few things however. I have standardized the naming of a few packages depending whether they are based on python 2 or 3. This package is the python 3 version of aplpy from now on. If you want the python 2 version, there is a new python2-aplpy package. Regarding the dependencies, aplpy now requires pyavm and astropy. The latter replaces quite a few packages, including pywcs and pyfits. I do not expect the upgrade to go smoothly. I would suggest removing pywcs, pyfits, pyregion, vo, aplpy, etc. and the reinstall from scratch. Given all the changes and new packages I had to make for the dependencies it is not unlikely I have forgotten to add some dependencies here and there. Please let me know. Also, if you need montage at the moment, do *not* upgrade. There seems to be a problem with the montage_wrapper package (yet another new dependency). Bug already reported.



mboquien commented on 2011-10-23 07:35

I have updated the dependencies.

clu commented on 2011-10-23 03:19

python-pyfits has now been split into python2-pyfits and python-pyfits.

mboquien commented on 2011-07-19 16:46

updated to require python2-numpy instead of python-numpy

mboquien commented on 2010-10-19 01:21

Package updated to 0.9.5.
* I have changed the dependency from python to python2
* I have added the pyregion dependency to plot ds9 region files
* The migration from python 2.6 to 2.7 upset matplotlib, problem solved by removing ~/.matplotlib/fontList.cache manually

All comments