Package Details: python-apt 2.3.0-1

Git Clone URL: https://aur.archlinux.org/python-apt.git (read-only, click to copy)
Package Base: python-apt
Description: Python binding of libapt-pkg
Upstream URL: https://tracker.debian.org/pkg/python-apt
Keywords: apt debian python
Licenses: GPL2
Submitter: JonnyJD
Maintainer: tallero (HaaTa)
Last Packager: tallero
Votes: 11
Popularity: 0.000025
First Submitted: 2014-06-11 08:37
Last Updated: 2021-10-26 12:29

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

dylan commented on 2017-04-05 22:40

Progress!

The latest version of this package builds just fine with apt >= 1.4. The only problem is that the latest apt version in the aur is 1.3.2. Therefore I won't be able to update this package until the apt aur package is updated to 1.4 or above.

apt 1.4 is only in debian testing/unstable so I don't think there's a rush to update python-apt. [1]

TL;DR: I'm going to keep this package's version inline with the version of apt in the aur.

[1] https://packages.debian.org/search?keywords=apt

dylan commented on 2017-04-05 22:29

Thanks for the archive link @jdtournier, I've updated the source link so at least the package actually builds and installs now.

jdtournier commented on 2017-04-03 10:00

In case it helps: the current version (1.1.0~beta5) is no longer hosted on the Debian FTP repo, but the same file can be found from the Ubuntu archives. I just modified the 'source' line to:

source=(https://launchpad.net/ubuntu/+archive/primary/+files/${_pkgname}_$pkgver.tar.xz

and it worked fine.

It looks like you'll need to also update apt to version 1.4.0 before python-apt 1.4.0 will compile, so maybe this fix is good enough for now?

guest73 commented on 2017-03-26 20:26

The problem is back now
Failure while downloading http://ftp.debian.org/debian/pool/main/p/python-apt/python-apt_1.1.0~beta5.tar.xz

There is not python-apt_1.1.0~beta5.tar.xz, I can see only python-apt_1.4.0~beta2.tar.xz. I think an update is needed.

cellisten commented on 2017-03-17 15:46

I can confirm the problem, haven't figured out a solution though.

dylan commented on 2017-03-09 02:42

I'm getting an error when I try to build the newest version of python-apt (1.4.0~beta2). Here's the terminal output:

https://gist.githubusercontent.com/dylanaraps/114fb014e5169aec154eecaaf570ae0d/raw/0c51ef505b6a3b392f93cc03c2690c85c725a5e5/python-apt-log

Any help is appreciated.

dylan commented on 2017-03-09 00:33

I'm updating the package to 1.4.0~beta2, sorry for the delay.

dylan commented on 2017-01-29 02:19

This PKGBUILD works if the version is changed to '1.1.0~beta5'. Could the maintainer please update the PKGBUILD?

aninstance commented on 2017-01-13 20:32

Remains un-updated, as per flag of 2016-09-19:

Failure while downloading http://ftp.debian.org/debian/pool/main/p/python-apt/python-apt_1.1.0~beta4.tar.xz

JonnyJD commented on 2016-08-28 12:56

Well, the actual problem wasn't the sha, but a broken apt build.
Anyways, updated now, since apt is fixed since yesterday.

The real shame is that Debian removes the source files that often..
So prepare for this package to break with 404 as soon as beta5 or similar is out.