Package Details: python-asdf 2.15.0-1

Git Clone URL: https://aur.archlinux.org/python-asdf.git (read-only, click to copy)
Package Base: python-asdf
Description: A Python tool for reading and writing Advanced Scientific Data Format (ASDF) files
Upstream URL: https://asdf.readthedocs.io
Licenses: BSD
Submitter: Universebenzene
Maintainer: Universebenzene
Last Packager: Universebenzene
Votes: 0
Popularity: 0.000000
First Submitted: 2018-02-14 11:01 (UTC)
Last Updated: 2023-04-05 05:24 (UTC)

Latest Comments

1 2 3 Next › Last »

Universebenzene commented on 2022-02-04 08:53 (UTC)

@simona No idea what happened to your system's python environment.

simona commented on 2022-02-03 19:56 (UTC)

yes, also if it write:
import astropy_sphinx_theme
ModuleNotFoundError: No module named 'astropy_sphinx_theme'
================================================= short test summary info =================================================
FAILED sphinx_astropy/tests/test_conf.py::test_conf - assert 2 == 0
FAILED sphinx_astropy/tests/test_conf.py::test_intersphinx_toggle - assert 2 == 0
but package python-sphinx-astropy is installed.
it's all very strange

Universebenzene commented on 2022-02-03 19:06 (UTC)

@simona Are you sure python-sphinx-astropy is correctly installed? I tried yay -S python-asdf and no error occurs

simona commented on 2022-02-03 18:54 (UTC)

"yay -S python-sphinx-astropy" is now perfect.
yay -S python-asdf
say:
Running Sphinx v4.4.0
ERROR: the documentation requires the sphinx-astropy package to be installed

Configuration error:
The configuration file (or one of the modules it imports) called sys.exit()

Universebenzene commented on 2022-02-03 18:49 (UTC) (edited on 2022-02-03 18:49 (UTC) by Universebenzene)

@simona remove the ~/.cache/yay/python-sphinx-astropy/ directory and try again

simona commented on 2022-02-03 18:37 (UTC)

:-(
FAILED sphinx_astropy/tests/test_conf.py::test_conf - assert 2 == 0
FAILED sphinx_astropy/tests/test_conf.py::test_intersphinx_toggle - assert 2 == 0

Universebenzene commented on 2022-02-03 18:27 (UTC)

@simona I updated python-sphinx-astropy. You can try again.

simona commented on 2022-02-03 18:17 (UTC)

yay -S --asdeps python-sphinx-astropy
give me
E assert 2 == 0
sphinx_astropy/tests/test_conf.py:36: AssertionError

simona commented on 2022-02-03 18:15 (UTC)

@universebenzene yay -S python-asdf
give me
ERROR: the documentation requires the sphinx-astropy package to be installed
so I tried with
yay -S sphinx-astropy
but fails.

Universebenzene commented on 2022-02-03 18:10 (UTC) (edited on 2022-02-03 18:12 (UTC) by Universebenzene)

@simona Use yay -S python-asdf or yay -S --asdeps python-sphinx-astropy. I said yay should solve the dependencies AUTOMATICALLY. Why don't you use yay to install python-asdf?