Package Details: python-autopep8 1.2.4-1

Git Clone URL: https://aur.archlinux.org/python-autopep8.git (read-only)
Package Base: python-autopep8
Description: Automatically formats Python code to conform to the PEP 8 style guide.
Upstream URL: http://pypi.python.org/pypi/autopep8/1.2.4
Licenses: MIT
Submitter: mmirate
Maintainer: neosilky
Last Packager: neosilky
Votes: 35
Popularity: 0.458067
First Submitted: 2012-07-22 20:59
Last Updated: 2016-07-11 15:28

Dependencies (2)

Required by (2)

Sources (1)

Latest Comments

jose1711 commented on 2016-07-24 20:47

conflicts with autopep8

arctico commented on 2016-07-05 18:04

Hey, pep8-python3 has been renamed to python-pycodestyle.

neosilky commented on 2015-10-22 13:44

Hi guys, I've taken over as maintainer for now. I've updated it to the latest version.

Let me know if anything breaks.

aleb commented on 2015-10-06 10:35

I tried to update the package but I failed, probably because only the maintainer can do it. It's a matter of changing 1.1.1 to 1.2.1 and using the 4167555f521ddd69b66f13819604f3db md5 sum.

contrebasse commented on 2015-10-06 09:41

1.2.1 is out, and the current version crashes with python 3.5.

antony commented on 2015-03-03 03:23

1.1.1 is out.

Lykve commented on 2014-09-12 08:30

Hi a new minor version, 1.0.4, was released on 9th of september.
Thanks for your work :)

https://pypi.python.org/pypi/autopep8/1.0.4

mmirate commented on 2014-03-28 16:19

pkgrel bumped.

garyvdm commented on 2014-03-27 18:49

Please bumb pkgrel for python 3.4.

ytj commented on 2013-01-02 06:20

==> Validating source files with md5sums...
autopep8-0.8.1.tar.gz ... Passed
==> Extracting Sources...
-> Extracting autopep8-0.8.1.tar.gz with bsdtar
==> Starting package()...
Traceback (most recent call last):
File "setup.py", line 5, in <module>
from setuptools import setup
ImportError: No module named 'setuptools'
==> ERROR: A failure occurred in package().
Aborting...



###
It seems that you should put python-distrubite in makedepends array.

All comments