Package Details: python-b2sdk 1.13.0-1

Git Clone URL: https://aur.archlinux.org/python-b2sdk.git (read-only, click to copy)
Package Base: python-b2sdk
Description: Python library to access B2 cloud storage.
Upstream URL: https://github.com/Backblaze/b2-sdk-python
Licenses: MIT
Submitter: 2bluesc
Maintainer: 2bluesc
Last Packager: 2bluesc
Votes: 3
Popularity: 0.046868
First Submitted: 2019-05-04 06:17
Last Updated: 2021-12-07 14:52

Latest Comments

« First ‹ Previous 1 2

eta-carinae commented on 2021-04-04 13:36

The build of 1.5.0-1 fails if you don't have python-pip installed. I don't think that's required otherwise, so maybe it just needs to be added to makedepends.

2bluesc commented on 2021-02-16 22:59

@ectospasm In my earlier post I included a link to the master branch of requirements.txt. The problem is still that no release of the command line tool including the update has been made. I'd expect that version to be v2.1.1 or v2.2.0.

This package and the backblaze-b2 follows releases, not arbitrary git hashes. These packages will remain unchanged until until the b2 command line tool has a release.

ectospasm commented on 2021-02-16 22:13

@2bluesc see the upstream comment thread. The requirements.txt on backblaze-b2 has been updated to show it must have a version of b2sdk prior to 1.3.0.

Not sure how that would work from a package maintainer's point of view, but not having b2sdk 1.3.0 broke duplicity for me.

ectospasm commented on 2021-02-15 20:12

Please raise an issue on the b2 command line tool repo asking for a release and I'll gladly update this package.

I don't use the b2 CLI program directly. duplicity is what broke for me, so the workaround for installing it from pip is sufficient for me, for now. Once Backblaze fixes this dependency problem, I'll upgrade both b2 and python-b2sdk when it hits the AUR.

Thanks for your attention.

2bluesc commented on 2021-02-15 18:32

@ectospasm I did update the package then reverted it because it broke backblaze-b2 package which is an old release that does not yet support v1.3.0 SDK. Upgrading this SDK would instantly break all installed backblaze-b2 instances.

My revert commit: 6bcdd5dcb582

Upstream requirements.txt to watch:

Unfortunately this is dependency hell where one package needs one version and another needs a different version. I favor not breaking installed packages (i.e. backblaze-b2) that I manage in over breaking upon upgrade (i.e. duplicity).

I'd expect Backblaze's packages to need the latest version, but this isn't the case. The release management on the Backblaze tools leaves quite a bit to be desired.

Please raise an issue on the b2 command line tool repo asking for a release and I'll gladly update this package.

ectospasm commented on 2021-02-15 18:21

@2bluesc I see you updated this package yesterday, but the package version still reads v1.2.0. v1.3.0 was released upstream on January 13, I'm marking this package as out of date since everything in the AUR about this package refers to the old one.

I've installed b2sdk via pip for the time being:

sudo pip install b2sdk

That fixed my duplicity-based backup script which backs up data to Backblaze.

smoak commented on 2020-07-17 21:57

Version 2.0.2 of b2 is available now which requires b2sdk>=1.1.4,<1.2.0 so this package can be updated

2bluesc commented on 2020-04-12 17:18

@drwho v0.1.8 is being packaged because the released (i.e. latest tag) version of backblaze-b2 package doesn't yet support b2sdk beyond v0.2.0

https://github.com/Backblaze/B2_Command_Line_Tool/blob/v1.4.2/requirements.txt

When the command line tool is updated to support the latest SDK I'll gladly upgrade.

drwho commented on 2020-02-18 07:24

I'm a bit concerned that v0.1.8 is still being packaged, when v1.0.2 is the latest supported version at Github (https://github.com/Backblaze/b2-sdk-python/releases/tag/v1.0.2).

dcelasun commented on 2019-09-02 12:09

b2-sdk depends on arrow>=0.8.0,<0.13.1, but this package has arrow>=0.8.0 which is causing a warning spam with b2-cli.