Package Details: python-conda-git 4.6.0a2.r0.gc467517ca-2

Git Clone URL: https://aur.archlinux.org/python-conda-git.git (read-only)
Package Base: python-conda-git
Description: OS-agnostic, system-level binary package manager and ecosystem
Upstream URL: http://conda.pydata.org/docs/
Licenses: BSD
Conflicts: python-conda, python-conda-env
Provides: python-conda, python-conda-env
Submitter: cyrevolt
Maintainer: cyrevolt
Last Packager: cyrevolt
Votes: 1
Popularity: 0.000000
First Submitted: 2016-04-08 07:38
Last Updated: 2018-05-02 00:30

Dependencies (6)

Required by (2)

Sources (1)

Latest Comments

1 2 Next › Last »

y0uCeF commented on 2019-06-06 13:15

I had to install python-tqdm, python-libarchive-c and build conda-package-handling from its official Github repo https://github.com/conda/conda-package-handling to get conda to work. It complained about the aforementioned missing python modules. The first two could be added as deps however the last one has to be created as a package in AUR because I couldn't find it. I am running version 4.7.1.r5.ga18b5a3d4.

cyrevolt commented on 2018-05-02 00:32

I have figured out how to get conda-env to work and it is now included. Integration for tcsh is also fixed now. Enjoy! :)

cyrevolt commented on 2018-02-21 21:18

The issues are now fixed and it works again. :) I tested with bash, fish, and zsh.

You may need to set pkgs_dirs in your condarc. To do so, you can use the CLI: https://github.com/conda/conda/blob/caedbbfe37860f3b61466408cc9ae199b3ffe910/CHANGELOG.md#4315-2017-03-20

Thanks everyone for helping and enjoy conda! :)

cyrevolt commented on 2018-02-20 22:31

Yes they changed quite a lot. Please just use the stable python-conda for now, where I just fixed everything a few hours ago. I will update this PKGBUILD also when I find the time tomorrow. :)

strayArch commented on 2018-02-20 20:40

PKGBUILD should have install -Dm 644 shell/etc/fish/conf.d/conda.fish changed to install -Dm 644 conda/shell/etc/fish/conf.d/conda.fish . flagged out-of-date as well

cyrevolt commented on 2017-05-08 19:50

I just fixed the fish script installation, as they changed the path to it to align it with the current version of fish. What you took there was the xonsh script @petronny. :D
I couldn't figure out where to put it from the docs. If anyone knows, please tell me so I can add it. :)

cyrevolt commented on 2017-05-07 15:56

Yeah, thanks a lot, I have updated the dependency here now as well. It's a bit odd now because of the package names (python-ruamel-yaml vs python-ruamel.yml).

petronny commented on 2017-05-07 08:44

Hi, I have replaced python-ruamel.yaml-hg with python-ruamel-yaml since I cannot build python-ruamel.yaml-hg from source anymore and python-ruamel-yaml is moved to [community] and should be in good maintenance.

cyrevolt commented on 2017-01-24 22:50

The issue is now "fixed", using a "testing" installation as they mention it in `setup.py`.

cyrevolt commented on 2017-01-10 23:34

Sorry for this; the current version of conda does not create the binaries (conda, activate, deactivate) anymore. If you are using the fish shell, you are not affected by this. In other cases, I recommend you to use the stable version https://aur.archlinux.org/packages/python-conda and downgrade to v4.2.12-3 as mentioned in the comment there.