Package Details: python-cookiecutter 1.6.0-1

Git Clone URL: https://aur.archlinux.org/python-cookiecutter.git (read-only)
Package Base: python-cookiecutter
Description: A command-line utility that creates projects from project templates
Upstream URL: https://github.com/audreyr/cookiecutter
Licenses: BSD
Groups: devel
Submitter: meirkr
Maintainer: meirkr
Last Packager: meirkr
Votes: 11
Popularity: 0.147535
First Submitted: 2013-10-15 16:01
Last Updated: 2017-11-23 20:08

Latest Comments

meirkr commented on 2017-11-23 20:10

Updated to 1.6.0

johannesbrahms commented on 2017-11-22 18:30

==> Validating source files with md5sums...
1.5.1.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build python-cookiecutter.

meirkr commented on 2017-08-10 19:51

What's the output of:
pacman -Qs ',*jinja.*'

marmistrz commented on 2017-08-09 08:07

pkg_resources.DistributionNotFound: The 'jinja2-time>=0.1.0' distribution was not found and is required by cookiecutter

JohnRobson commented on 2016-07-09 16:26

Dependencies to install:

python2-arrow python-arrow
python2-jinja-time python-jinja-time

meirkr commented on 2016-04-05 09:15

Updated to 1.4.0

SpotlightKid commented on 2016-04-02 22:04

I created a python-jinja-time package for python 2 and 3.

Here's a diff to bring this package to 1.4.0:

https://gist.github.com/anonymous/e9be62e0d31fe4d332dbb52105b9df2a

SpotlightKid commented on 2016-04-02 18:33

@aboe, @meikr: we will also need a python-jinja-time package.

meirkr commented on 2016-03-14 22:09

@aboe: Thanks.

It's not in a released version yet (1.3.0 does not depend on it). Will do when a new release includes it.

aboe commented on 2016-03-14 18:28

@meirkr I have added python-poyo to aur so it can be a depency for python-cookiecutter...

see: https://github.com/audreyr/cookiecutter/blob/master/setup.py#L33

meirkr commented on 2016-03-13 21:07

Updated to 1.3.0

meirkr commented on 2015-08-13 14:26

Added python-click dependency. Thanks @abdo.

abdo commented on 2015-08-02 12:53

The dependency on python-click is missing in the PKGBUILD.

meirkr commented on 2015-07-11 17:46

Thanks SpotlightKid, updated the package and subscribed to the issue.

SpotlightKid commented on 2015-07-10 14:35

I put the following in the PKGBUILD and it seems that cookiecutter works with python-click 4.0 without problems (all tests pass with Python 3.4):

prepare() {
cd "$srcdir/${_pkgname}-${pkgver}"
sed -i -e 's/click<4\.0/click/' setup.py
}

I have opened an issue for cookiecutter on this:

https://github.com/audreyr/cookiecutter/issues/472

eigengrau commented on 2015-07-02 14:11

This seems to depend on click<4.0

> pkg_resources.DistributionNotFound: The 'click<4.0' distribution was not found and is required by cookiecutter

meirkr commented on 2015-01-20 10:19

Updated to 0.9.0

meirkr commented on 2014-11-03 21:47

Updated to 0.8.0

meirkr commented on 2014-08-09 16:34

Updated to 0.7.2

meirkr commented on 2014-06-17 07:21

Updated to 0.7.1.

SpotlightKid commented on 2014-06-17 01:52

The latest version is 0.7.1.