Package Details: python-cryptodatahub 0.12.5-1

Git Clone URL: https://aur.archlinux.org/python-cryptodatahub.git (read-only, click to copy)
Package Base: python-cryptodatahub
Description: Repository of cryptography-related data
Upstream URL: https://gitlab.com/coroner/CryptoDataHub
Licenses: MPL-2.0
Submitter: carlosal1015
Maintainer: carlosal1015
Last Packager: carlosal1015
Votes: 0
Popularity: 0.000000
First Submitted: 2023-05-20 02:21 (UTC)
Last Updated: 2024-05-28 01:02 (UTC)

Latest Comments

MarsSeed commented on 2023-08-03 21:03 (UTC)

Python's build and install doesn't complain after all because of the missing pathlib2 (which is unnecessary for the execution of the code itself).

But the resulting MEDATATA file will contain an erroneous entry (the last one):

$ cat /usr/lib/python3.11/site-packages/CryptoDataHub-0.10.0.dist-info/METADATA | grep pathlib2

Requires-Dist: pathlib2 (==2.3.7.post1) ; python_version < "3.4"
Requires-Dist: pathlib2 (==2.3.7.post1) ; python_version < '3'
Requires-Dist: pathlib2 ; python_version >= "3.4"

MarsSeed commented on 2023-07-31 16:29 (UTC)

Actually I would just use a sed expression to delete the requirements lines with pathlib2 in them.

MarsSeed commented on 2023-07-31 16:28 (UTC)

I think you still need to patch the requirements.txt to remove its declaration of pathlib2, otherwise setup will complain.

And also you need to bump pkgrel to 2, to force a rebuild with the changed metadata.

carlosal1015 commented on 2023-07-31 16:05 (UTC)

Thanks @MarsSeed

MarsSeed commented on 2023-07-31 16:03 (UTC)

The requirements.txt should be patched to remove pathlib2;python_version>="3.4", as pathlib2 is part of the Python stdlib, and this module is only needed on some old Python 3.x versions, not for the current Python 3.8+ releases.