Package Details: python-damask 3.0.0beta2-1

Git Clone URL: https://aur.archlinux.org/damask.git (read-only, click to copy)
Package Base: damask
Description: Pre- and post-processing tools for DAMASK
Upstream URL: https://damask.mpie.de
Keywords: Materials Science
Licenses: AGPL-3.0-or-later
Submitter: MartinDiehl
Maintainer: MartinDiehl
Last Packager: MartinDiehl
Votes: 2
Popularity: 0.000000
First Submitted: 2021-10-07 10:49 (UTC)
Last Updated: 2024-05-30 16:32 (UTC)

Pinned Comments

MartinDiehl commented on 2024-03-21 14:37 (UTC)

due to a malformed version (3.0.0~beta, which is considered larger than 3.0.0), updating the package requires to uninstall version which tilde in the version string.

Latest Comments

entshuld commented on 2024-05-12 23:40 (UTC)

In case that this is useful: (from the git repository 43b8bb6fa Merge branch 'PETSc-3.21_compatible' into 'development')


From 0f2d72ed4d490cf073e10deabeecfdb9bcf0250a Mon Sep 17 00:00:00 2001
From: hi <you_know_me@uni.dot>
Date: Mon, 13 May 2024 01:36:19
Subject: [PATCH] fftw3_mpi shotgun

---
 CMakeLists.txt     | 5 ++++-
 src/CMakeLists.txt | 1 +
 2 files changed, 5 insertions(+), 1 deletion(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 676a7f2f6..be2d447e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -138,7 +138,10 @@ if(fYAML_FOUND STREQUAL "1")
     set(CMAKE_C_FLAGS_${CMAKE_BUILD_TYPE} "${CMAKE_C_FLAGS_${CMAKE_BUILD_TYPE}} -I${fYAML_INCLUDE_DIR}")
 endif()

-set(CMAKE_Fortran_LINK_EXECUTABLE "${CMAKE_Fortran_LINK_EXECUTABLE} ${BUILDCMD_POST}")
+set(CMAKE_Fortran_LINK_EXECUTABLE "${CMAKE_Fortran_LINK_EXECUTABLE} ${BUILDCMD_POST} -lfftw3 -lm -lfftw3_mpi")
+
+set(${FFTW3_LIBRARIES} "-lfftw3_mpi ${FFTW3_LIBRARIES}")
+set(${FFTW3_LDFLAGS} "-lfftw3_mpi ${FFTW3_LDFLAGS}")

 message("Fortran Compiler Flags:\n${CMAKE_Fortran_FLAGS_${CMAKE_BUILD_TYPE}}\n")
 message("C Compiler Flags:\n${CMAKE_C_FLAGS_${CMAKE_BUILD_TYPE}}\n")
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 1aef09c3f..25d14f5b5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -6,6 +6,7 @@ file(GLOB solver-sources CONFIGURE_DEPENDS ${DAMASK_SOLVER_LOWER}/*.f90)
 if(NOT CMAKE_BUILD_TYPE STREQUAL "SYNTAXONLY")
     add_executable(${executable-name} ${damask-sources} ${solver-sources})
     install(TARGETS ${executable-name} RUNTIME DESTINATION bin)
+    target_link_libraries(${executable-name} fftw3_mpi fftw3)
 else()
     add_library(${executable-name} OBJECT ${damask-sources} ${solver-sources})
     exec_program(mktemp OUTPUT_VARIABLE nothing)
-- 
2.45.0


In PKGBUILD (build):


  sed -i "s/.*/${pkgver_}/g" "${srcdir}"/"${pkgbase}"/VERSION
  cd ${pkgbase}/python
  python -m build --wheel --no-isolation

Should pkgver_ be _pkgver ? Thanks for DAMASK.

MartinDiehl commented on 2024-03-21 14:37 (UTC)

due to a malformed version (3.0.0~beta, which is considered larger than 3.0.0), updating the package requires to uninstall version which tilde in the version string.

archuser2021 commented on 2022-08-20 13:05 (UTC) (edited on 2022-08-20 13:12 (UTC) by archuser2021)

Hi,

Thank you for packaging your excellent software on AUR!

The package failed to build with latest petsc.


PETSC_DIR:
/opt/petsc/linux-c-opt

-- Checking for modules 'PETSc>=3.12.0;PETSc<3.17.0'
--   Package dependency requirement 'PETSc < 3.17.0' could not be satisfied.
Package 'PETSc' has version '3.17.4', required version is '< 3.17.0'
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:607 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPkgConfig.cmake:829 (_pkg_check_modules_internal)
  CMakeLists.txt:13 (pkg_check_modules)

Best,