Package Details: python-dcos 0.5.5-1

Git Clone URL: https://aur.archlinux.org/dcos-cli.git (read-only)
Package Base: dcos-cli
Description: DC/OS Command Line Interface
Upstream URL: https://github.com/dcos/dcos-cli
Licenses: EPL
Submitter: mtorromeo
Maintainer: mtorromeo
Last Packager: mtorromeo
Votes: 1
Popularity: 0.000087
First Submitted: 2016-08-15 08:38
Last Updated: 2017-09-28 08:26

Latest Comments

yan12125 commented on 2017-02-14 18:14

Hello, as CPython is moved to GitHub, the original python-git is moved back to python-gitpython

mtorromeo commented on 2016-12-13 11:58

Dependency added and package updated to 0.4.14

galaux commented on 2016-12-13 11:18

Hi Massimiliano,

Running the CLI after a fresh install, I get the following stacktrace:

```
$ dcos
Traceback (most recent call last):
File "/usr/bin/dcos", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 3015, in <module>
@_call_aside
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2999, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 3028, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 655, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 963, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 849, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'virtualenv<16.0,>=13.0' distribution was not found and is required by dcoscli
```

Installing `python-virtualenv` fixes it so it seems it is a dependency.