Package Details: python-django-rest-framework 3.9.2-1

Git Clone URL: https://aur.archlinux.org/python-django-rest-framework.git (read-only)
Package Base: python-django-rest-framework
Description: Awesome web-browsable Web APIs
Upstream URL: https://github.com/tomchristie/django-rest-framework
Licenses: MIT
Submitter: thelinuxguy
Maintainer: fryfrog
Last Packager: fryfrog
Votes: 3
Popularity: 0.627472
First Submitted: 2015-09-12 00:35
Last Updated: 2019-03-28 16:03

Dependencies (7)

Sources (1)

Latest Comments

ValHue commented on 2019-03-03 07:46

New release. Please, update to 3.9.1:

https://github.com/encode/django-rest-framework/archive/3.9.1.tar.gz

thelinuxguy commented on 2017-11-29 23:50

I just added a couple of optdepends.
There are more, but they are not available yet in repos/aur so I didn't add them. If someone really needs them I can package them too.

Currently missing are django-filter and django-guardian

pancakes commented on 2017-11-28 18:39

Hello,

According to http://www.django-rest-framework.org/topics/documenting-your-api/#built-in-api-documentation, the PKGBUILD could use "python-pygments" and "python-markdown" as optdepends.

They're required for syntax highlighting for the docstrings/documentation in django rest framework's web interface to the API.

I've only verified requiring python-markdown, didn't try anything that uses pygments.

wooptoo commented on 2017-11-01 17:03

Thanks, it's yaourt's fault then

thelinuxguy commented on 2017-11-01 17:02

@wooptoo it's a split package so when you build it, you get both.
You don't need to install them both. You are probably using some aur wrapper that does that. In that case please contact them on how to resolve the issue.

wooptoo commented on 2017-11-01 15:37

Can this package be configured so that it doesn't also install python2-django-rest-framework ?

thelinuxguy commented on 2016-08-29 11:36

done. thanks for notifying me

christoph.gysin commented on 2016-08-29 06:50

It seems that you forgot to update the sha256sums on the last update.

Also, to avoid conflicts with other packages in the tarball cache, please specify the source as:

source=("${pkgname}-${pkgver}.tar.gz::https://github.com/tomchristie/django-rest-framework/archive/${pkgver}.tar.gz")