Package Details: python-efl 1.21.0-1

Git Clone URL: (read-only)
Package Base: python-efl
Description: Python bindings for the Enlightenment Foundation Libraries
Upstream URL:
Licenses: GPL3, LGPL3
Submitter: Scimmia
Maintainer: llde
Last Packager: llde
Votes: 55
Popularity: 0.043854
First Submitted: 2013-12-08 20:40
Last Updated: 2018-09-03 15:36

Latest Comments

1 2 3 4 Next › Last »

davemds commented on 2018-08-26 09:59

Ok, the new 1.21 release is out and should fix the python 3.7 issue, as it is generated using Cython 0.28

davemds commented on 2018-08-15 06:12

Yep, indeed seems the cython version we are using is too old for py3.7, we was generating the code with an old cython (0.23.5) because of this issue:

In the next few days I'm going to release python-efl-1.21.0 . I will generate the new release with the most recent cython available. This move should fix the current 3.7 issue, hopefully we will not fall again in T5589.

noxpo commented on 2018-08-07 09:12

This stopped working with python 3.7, apparently C files need to be regened with cython >= 0.27.3. Pretty pleeze.

lightdot commented on 2017-11-30 01:36

The build logs are gone I'm afraid, all I can remember is that the build failed and the error(s) led me to the mentioned solution.

I'm using aurutils helper scripts combined with a clean chroot build environment to handle AUR packages so I can stage the build again if needed. Is anyone else having issues? If not perhaps it can wait until the next version and I'll pay more attention than.

llde commented on 2017-11-25 12:44

@lightdot this is strange. Which issue did you have?

lightdot commented on 2017-11-19 23:43

Hm, python-efl 1.20.0-1 built fine for me in the past, but 1.20.0-2 didn't. I had to add mesa and libdrm to makedepends.

llde commented on 2017-11-19 13:33

@noxpo fixed thanks

noxpo commented on 2017-11-14 09:54

Breaking change: At the download site, the archive file postfix changed from "gz" to "xz" since xz compression is apparently used now. Consequetly, the checksum also changed.

llde commented on 2016-09-17 21:52

This package doesn't require elementary no more from 1.18 as elementary is included in efl package and no more provided as a standalone package.
I tested right now and works for me witohut any issue.
Maybe an old PKGBUILD is readed form the cache

bowhuntr commented on 2016-09-13 11:04

This won't build.

pacaur -S python-efl
resolving dependencies...
warning: cannot resolve "elementary", a dependency of "python-efl"
:: The following package cannot be upgraded due to unresolvable dependencies: