Package Details: python-empy 3.3.3-1

Git Clone URL: https://aur.archlinux.org/python-empy.git (read-only)
Package Base: python-empy
Description: A powerful and robust templating system for Python.
Upstream URL: http://www.alcyone.com/software/empy
Licenses: LGPL
Submitter: Snowman
Maintainer: dante_666
Last Packager: mis
Votes: 8
Popularity: 0.000016
First Submitted: 2007-04-05 03:56
Last Updated: 2017-02-15 19:50

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

bchretien commented on 2017-01-22 19:30

Disowning, feel free to update it

petronny commented on 2017-01-19 10:32

Hi please update it for python 3.6

unusual_thoughts commented on 2017-01-13 13:48

Package build fails on python 3.6 because of hard-coded chmod

It works with this patch:

diff --git a/PKGBUILD b/PKGBUILD
index 416ba0f..cabc7e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,5 +22,5 @@ package() {
python3 setup.py install -O2 --skip-build --prefix=/usr --root=${pkgdir}

# Make em.py executable
- chmod a+x ${pkgdir}/usr/lib/python3.5/site-packages/em.py
+ chmod a+x "${pkgdir}$(python3 -c 'import site; print(site.getsitepackages()[0])')/em.py"
}

de-vries commented on 2015-03-19 19:56

Doesn't build without python-setuptools. Should be a makedepend?

Anonymous comment on 2012-05-30 09:23

python-empy now by default tries to build against python3 which isn't supported in empy as it seems. Unfortunately a simple '2to3' is not enough.