Package Details: python-eth-utils 4.1.1-1

Git Clone URL: https://aur.archlinux.org/python-eth-utils.git (read-only, click to copy)
Package Base: python-eth-utils
Description: Common utility functions for python code that interacts with Ethereum
Upstream URL: https://github.com/ethereum/eth-utils
Licenses: MIT
Submitter: algebro
Maintainer: carlosal1015 (xuhcc)
Last Packager: carlosal1015
Votes: 0
Popularity: 0.000000
First Submitted: 2019-01-19 19:40 (UTC)
Last Updated: 2024-05-07 17:07 (UTC)

Latest Comments

xuhcc commented on 2023-01-03 18:35 (UTC)

@algebro any updates? I can help maintain this package too.

radrow commented on 2022-11-16 19:48 (UTC)

It works when you update pkgver to 2.0.0 and sha256sum to 52db91d58330a162dac5ff32775a4a1d97ac6dd2460deab5ab503389ae543c78

algebro commented on 2022-05-22 18:05 (UTC)

Hey guys--thanks for the bump. Unfortunately I no longer use this or the other python-eth* packages so I haven't been following upstream tags very closely.

@Kewl, would you be interested in taking over this and/or python-eth-hash/python-eth-typing? Let me know and I can hand them off.

Kewl commented on 2022-05-22 09:01 (UTC)

This is several versions behind, @algebro can you have a look or allow co-maintenance if you don't have time at the moment?

<deleted-account> commented on 2022-05-11 11:18 (UTC)

I get the following error and the build does not go through.

/usr/lib/python3.10/site-packages/setuptools/installer.py:27: SetuptoolsDeprecationWarning: setuptools.installer is deprecated. Requirements should be satisfied by a PEP 517 installer.
  warnings.warn(
WARNING: The wheel package is not available.
WARNING: The wheel package is not available.
Traceback (most recent call last):
  File "/home/USERNAME/.config/trizen/sources/python-eth-utils/src/eth-utils-1.8.4/setup.py", line 44, in <module>
    setup(
  File "/usr/lib/python3.10/site-packages/setuptools/__init__.py", line 153, in setup
    return distutils.core.setup(**attrs)
  File "/usr/lib/python3.10/distutils/core.py", line 108, in setup
    _setup_distribution = dist = klass(attrs)
  File "/usr/lib/python3.10/site-packages/setuptools/dist.py", line 459, in __init__
    _Distribution.__init__(
  File "/usr/lib/python3.10/distutils/dist.py", line 292, in __init__
    self.finalize_options()
  File "/usr/lib/python3.10/site-packages/setuptools/dist.py", line 837, in finalize_options
    ep(self)
  File "/usr/lib/python3.10/site-packages/setuptools/dist.py", line 858, in _finalize_setup_keywords
    ep.load()(self, ep.name, value)
  File "/home/USERNAME/.config/trizen/sources/python-eth-utils/src/eth-utils-1.8.4/.eggs/setuptools_markdown-0.4.1-py3.10.egg/setuptools_markdown.py", line 43, in long_description_markdown_filename
    output = pypandoc.convert(markdown_filename, 'rst', format='md')
AttributeError: module 'pypandoc' has no attribute 'convert'