Package Details: python-fafclient 0.18.1-2

Git Clone URL: https://aur.archlinux.org/python-fafclient.git (read-only)
Package Base: python-fafclient
Description: Forged Alliance Forever - Lobby Client. Community-driven client system for Supreme Commander: Forged Alliance.
Upstream URL: http://www.faforever.com/
Licenses: GPL3
Replaces: python2-fafclient
Submitter: sandwormsurfer
Maintainer: sandwormsurfer
Last Packager: sandwormsurfer
Votes: 3
Popularity: 0.629544
First Submitted: 2017-06-09 10:55
Last Updated: 2019-01-28 13:44

Latest Comments

dcelasun commented on 2019-03-26 19:51

Missing python-pyqtwebengine dependency.

sandwormsurfer commented on 2019-01-28 13:47

@polygon_dust: thanks for the report, should be fixed now?

polygon_dust commented on 2019-01-27 20:38

Solution to :"ModuleNotFoundError: No module named 'sip'". Trying installing Python-sip or Python2-sip. Conclusion------------------------------------------------------------------ Please add Python-sip/Python2-sip to dependencies.

polygon_dust commented on 2019-01-27 20:11

Compile failed #2: Note: checking out '0.18.1'.

You are in 'detached HEAD' state. You can look around, make experimental changes and commit them, and you can discard any commits you make in this state without impacting any branches by performing another checkout.

If you want to create a new branch to retain commits you create, you may do so (now or later) by using -b with the checkout command again. Example:

git checkout -b <new-branch-name>

HEAD is now at 8bbcdf50 fix changelog entries for 0.18.1 ==> Starting pkgver()... ==> Removing existing $pkgdir/ directory... ==> Starting build()... Traceback (most recent call last): File "setup.py", line 5, in <module> import sip ModuleNotFoundError: No module named 'sip' ==> ERROR: A failure occurred in build(). Aborting...

B15HOP commented on 2018-12-06 04:55

I have almost got this package installed but then got snagged on 32bit libs.

Is there a 64bit version of FAF? I really don't want to mess around with drivers just to install this package.

Win8Error commented on 2018-09-07 15:48

Compile failed:

==> Beginne prepare()... Hinweis: Checke '0.18.1' aus.

Sie befinden sich im Zustand eines 'losgelösten HEAD'. Sie können sich umschauen, experimentelle Änderungen vornehmen und diese committen, und Sie können alle möglichen Commits, die Sie in diesem Zustand machen, ohne Auswirkungen auf irgendeinen Branch verwerfen, indem Sie einen weiteren Checkout durchführen.

Wenn Sie einen neuen Branch erstellen möchten, um Ihre erstellten Commits zu behalten, können Sie das (jetzt oder später) durch einen weiteren Checkout mit der Option -b tun. Beispiel:

git checkout -b <neuer-branchname></neuer-branchname>

HEAD ist jetzt bei 8bbcdf50 fix changelog entries for 0.18.1 ==> Beginne pkgver()... ==> Entferne existierendes $pkgdir/ Verzeichnis... ==> Beginne build()... Traceback (most recent call last): File "setup.py", line 5, in <module> import sip ModuleNotFoundError: No module named 'sip' ==> FEHLER: Ein Fehler geschah in build(). Breche ab...</module>

sandwormsurfer commented on 2018-03-14 07:34

I forgot to push that, thanks.

codemonkey commented on 2018-03-14 07:11

jsonschema is required for faf to work. Installing with pip worked for me.

pip install jsonschema

sandwormsurfer commented on 2017-11-28 20:05

done, thanks.

sjrasti commented on 2017-11-28 15:31

You should add "qt5-multimedia" as a dependency, without it, it doesn't work.