Package Details: python-flask-limiter 3.5.1-1

Git Clone URL: https://aur.archlinux.org/python-flask-limiter.git (read-only, click to copy)
Package Base: python-flask-limiter
Description: Rate limiting for flask applications
Upstream URL: https://flask-limiter.readthedocs.org
Licenses: MIT
Submitter: RcrdBrt
Maintainer: BubuIIC (fryfrog)
Last Packager: fryfrog
Votes: 1
Popularity: 0.075455
First Submitted: 2018-07-08 17:47 (UTC)
Last Updated: 2024-02-28 23:39 (UTC)

Latest Comments

plenaerts commented on 2023-04-11 06:09 (UTC)

Perfect, thanks.

BubuIIC commented on 2023-04-10 11:09 (UTC)

This package should depend on python-importlib_resources.

@plenaerts: not exactly, no. Your error comes from https://aur.archlinux.org/packages/python-limits which is using importlib_resources since v3.3.0 (which the current aur package not yet provides). I'll update that though, please reinstall your version of python-flask-limits then.

plenaerts commented on 2023-04-10 06:01 (UTC)

This package should depend on python-importlib_resources.

 % python
Python 3.10.10 (main, Mar 13 2023, 21:04:51) [GCC 12.1.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> from flask_limiter import Limiter
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python3.10/site-packages/flask_limiter/__init__.py", line 4, in <module>
    from .errors import RateLimitExceeded
  File "/usr/lib/python3.10/site-packages/flask_limiter/errors.py", line 7, in <module>
    from .wrappers import Limit
  File "/usr/lib/python3.10/site-packages/flask_limiter/wrappers.py", line 10, in <module>
    from limits import RateLimitItem, parse_many
  File "/usr/lib/python3.10/site-packages/limits/__init__.py", line 5, in <module>
    from . import _version, aio, storage, strategies
  File "/usr/lib/python3.10/site-packages/limits/aio/__init__.py", line 1, in <module>
    from . import storage, strategies
  File "/usr/lib/python3.10/site-packages/limits/aio/storage/__init__.py", line 6, in <module>
    from .base import MovingWindowSupport, Storage
  File "/usr/lib/python3.10/site-packages/limits/aio/storage/base.py", line 5, in <module>
    from limits.storage.registry import StorageRegistry
  File "/usr/lib/python3.10/site-packages/limits/storage/__init__.py", line 12, in <module>
    from .base import MovingWindowSupport, Storage
  File "/usr/lib/python3.10/site-packages/limits/storage/base.py", line 6, in <module>
    from limits.util import LazyDependency
  File "/usr/lib/python3.10/site-packages/limits/util.py", line 11, in <module>
    import importlib_resources
ModuleNotFoundError: No module named 'importlib_resources'

BubuIIC commented on 2021-08-07 13:52 (UTC)

Thanks. Unfortunately github doesn't produce stable archives for source snapshots (not releases), so I switched to downloading from pypi instead.

dr460nf1r3 commented on 2021-08-07 06:30 (UTC)

Please fix the checksum, its not correct.