Package Details: python-flask-socketio-git 2.9.2-1

Git Clone URL: https://aur.archlinux.org/python-flask-socketio-git.git (read-only)
Package Base: python-flask-socketio-git
Description: Socket.IO integration for Flask applications
Upstream URL: http://github.com/miguelgrinberg/Flask-SocketIO/
Licenses: MIT
Conflicts: python-flask-socketio
Provides: python-flask-socketio
Submitter: zwindl
Maintainer: zwindl
Last Packager: zwindl
Votes: 2
Popularity: 0.009515
First Submitted: 2017-03-01 14:22
Last Updated: 2017-08-08 14:44

Latest Comments

zwindl commented on 2017-08-05 10:30

@elgaton Thanks a lot, fixed, I forgot how to deal with conflicts. I changed the gdbgui's dependent to the flask-socket-io community version. And this package will keep update.

elgaton commented on 2017-08-05 06:50

@zwindl: sorry for the late reply - now the version in [community] is up to date, but a possible solution would have been using the "provides" and "conflicts" PKGBUILD directories as follows:
# Mark this package as a "replacement" of python-flask-socketio
provides=('python-flask-socketio')
# Disallow installing the official "python-flask-socketio" at the same time
conflicts=('python-flask-socketio')
and having python-gdbgui depend on python-flask-socketio >= 2.9.1.

zwindl commented on 2017-07-13 12:29

@elgaton yes, it will, but the package in community is too old to satisfy the lowest dependency of gdb-gui, so I have to maintain a newer package. I appreciate if you could tell me a better way. Sorry for the inconvenience.

elgaton commented on 2017-07-11 20:24

This package should conflict with the python-flask-socketio package in [community] (https://www.archlinux.org/packages/community/any/python-flask-socketio/).