Package Details: python-flask-wtf 0.12-1

Git Clone URL: https://aur.archlinux.org/python-flask-wtf.git (read-only)
Package Base: python-flask-wtf
Description: Simple integration of Flask and WTForms
Upstream URL: https://pythonhosted.org/Flask-WTF/
Licenses: BSD
Submitter: FSX
Maintainer: ser
Last Packager: ser
Votes: 14
Popularity: 0.023453
First Submitted: 2010-09-19 09:10
Last Updated: 2015-07-28 13:21

Latest Comments

buhman commented on 2013-05-30 02:33

Adopted and switched to the python3 version of flask-wtf.

buhman commented on 2013-05-28 20:15

This package should be renamed to python2-flask-wtf

mitsuse commented on 2012-05-22 16:53

I fixed python2-wtforms.
Thanks.

fxkr commented on 2012-05-22 16:13

mitsuse, thanks!

Done, but your python2-wtforms pkgbuild is broken. See comments there.

mitsuse commented on 2012-05-21 15:07

Hi, I maintain "python-wtforms" (one of dependencies of "python-flask-wtf").
Today, I created "python2-wtforms" for near future.
Please change deps of this package some day.
("python-wtforms" is available yet, but it will become unavailable before long.)

Anonymous comment on 2011-10-19 06:47

python-flask is now python2-flask

FSX commented on 2011-01-25 14:24

I'll disown it. I'm using virtualenv now.

fxkr commented on 2011-01-22 22:23

FSX, can you please update or disown it? Thanks!

Anonymous comment on 2010-10-31 05:51

Fails to build.

==> Starting build()...
Traceback (most recent call last):
File "./setup.py", line 5, in <module>
import wtforms
File "/tmp/yaourt-tmp-asm/aur-python-wtforms/src/WTForms-0.4/wtforms/__init__.py", line 11, in <module>
from wtforms import validators, widgets
File "/tmp/yaourt-tmp-asm/aur-python-wtforms/src/WTForms-0.4/wtforms/validators.py", line 15
def __init__(self, message=u'', *args, **kwargs):
^
SyntaxError: invalid syntax

Changing the PKGBUILD to build with python2 instead of python fixes the problem.