Package Details: python-gdal-ecw 3.8.4-1

Git Clone URL: https://aur.archlinux.org/gdal-ecw.git (read-only, click to copy)
Package Base: gdal-ecw
Description: Python bindings for GDAL, with support to ECW format
Upstream URL: https://gdal.org/
Licenses: custom
Conflicts: python-gdal
Provides: python-gdal
Submitter: olivervbk
Maintainer: olivervbk (kikislater)
Last Packager: kikislater
Votes: 4
Popularity: 0.000019
First Submitted: 2020-10-08 19:58 (UTC)
Last Updated: 2024-03-10 03:15 (UTC)

Required by (14)

Sources (1)

Latest Comments

1 2 Next › Last »

kikislater commented on 2023-10-04 13:40 (UTC)

Looks like you are using an old java version. Could you update your java version ? at least jre8-openjdk for example

gds506 commented on 2023-10-04 13:14 (UTC)

I tried to install it but got this error. Any idea of how to fix it?

[ 92%] Generating gdal.jar, build/maven/gdal-3.7.2.jar, build/maven/gdal-3.7.2-sources.jar, build/maven/gdal-3.7.2.pom, build/maven/gdal-3.7.2-javadoc.jar
Buildfile: /var/tmp/pamac-build-gds506/gdal-ecw/src/gdal-3.7.2/swig/java/build.xml

init:
     [echo] version = 3.7.2

compile:
    [mkdir] Created dir: /var/tmp/pamac-build-gds506/gdal-ecw/src/build/swig/java/build/classes
    [javac] Compiling 82 source files to /var/tmp/pamac-build-gds506/gdal-ecw/src/build/swig/java/build/classes
    [javac] warning: [options] bootstrap class path not set in conjunction with -source 7
    [javac] error: Source option 7 is no longer supported. Use 8 or later.
    [javac] error: Target option 7 is no longer supported. Use 8 or later.

BUILD FAILED
/var/tmp/pamac-build-gds506/gdal-ecw/src/gdal-3.7.2/swig/java/build.xml:25: Compile failed; see the compiler error output for details.

Total time: 0 seconds
make[2]: *** [swig/java/CMakeFiles/java_binding.dir/build.make:105: swig/java/gdal.jar] Error 1
make[1]: *** [CMakeFiles/Makefile2:9960: swig/java/CMakeFiles/java_binding.dir/all] Error 2
make: *** [Makefile:146: all] Error 2
make: Leaving directory '/var/tmp/pamac-build-gds506/gdal-ecw/src/build'
==> ERROR: A failure occurred in build().
    Aborting...

MarsSeed commented on 2023-09-25 20:37 (UTC)

Thank you for your feedback.

In case you decide to wait for some time before updating, there's no harm in keeping the OOD flag though. (Only a more than 6 month old OOD flag allows automatic instant disowning in case an orphan request gets filed.)

+1: 10 minutes after your post, extra/gdal got updated to 3.7.2. :)

kikislater commented on 2023-09-25 19:01 (UTC)

Done for libecwj2 For 3.7.2, It could be better to wait from upstream extra as gdal is still 3.7.1 ... So removed from outdated. Feel free to add it outdated when 3.7.2 will be available in extra repo

MarsSeed commented on 2023-09-25 09:02 (UTC)

AUR/libecwj2 is a broken orphan. It needs a new maintainer.

mmdoublem commented on 2022-10-03 08:11 (UTC)

Feel free to take a look at the gdal-hdf4 for the new cmake process working.

kikislater commented on 2022-09-19 08:08 (UTC)

Works fine for me, please add me to contributor !

olivervbk commented on 2022-09-09 20:53 (UTC)

https://github.com/archlinux/svntogit-community/blame/packages/gdal/trunk/PKGBUILD

The community package was migrated to use cmake, and when I tried migrating the changes to this package, things stopped working. Unfortunately I didn't have too much time to debug and try different things.

If anyone has a working PKGBUILD, let me know and I'll test/merge it.

olivervbk commented on 2022-01-22 05:16 (UTC)

Updated to version 3.4.0, seems poppler patch isn´t needed anymore.

kikislater commented on 2021-10-17 11:53 (UTC)

Please add poppler patch =>

https://github.com/archlinux/svntogit-community/commit/fee18e5073726b7f00132851251f5714ff75043c#diff-3e341d2d9c67be01819b25b25d5e53ea3cdf3a38d28846cda85a195eb9b7203a