Package Details: python-googletrans 4.0.0rc1-1

Git Clone URL: (read-only, click to copy)
Package Base: python-googletrans
Description: Free Google Translate API for Python.
Upstream URL:
Licenses: MIT
Submitter: timschumi
Maintainer: timschumi
Last Packager: timschumi
Votes: 7
Popularity: 0.000027
First Submitted: 2019-10-03 12:02 (UTC)
Last Updated: 2021-11-22 12:06 (UTC)

Latest Comments

1 2 3 Next › Last »

timschumi commented on 2021-09-27 22:00 (UTC)

@D3SOX: This is intentional. googletrans doesn't accept anything else than that specific version of httpx, and it's a hard requirement.

D3SOX commented on 2021-09-27 21:23 (UTC)

error: could not find all required packages:
    python-httpx=0.13.3 (wanted by: python-googletrans)

yochananmarqos commented on 2021-09-14 23:46 (UTC)


Does running sed on the requirement file work?

I don't know, does it? What's your use case? As I already said,

I'm having no issues with translations with Dialect.

timschumi commented on 2021-09-14 20:15 (UTC)

You could install an old version of python-httpx via the downgrade tool, the package is still available on the archive servers.

Other than that, using sed would probably work, at least if other users are to be believed.

rafaelff commented on 2021-09-14 20:03 (UTC)

Since this package relies on a unavailable dependency, is there any recommended workaround (except using pip, obviously) ? Does running sed on the requirement file work?

timschumi commented on 2021-09-08 14:40 (UTC) (edited on 2021-09-08 14:40 (UTC) by timschumi)

@yochananmarqos: I'm aware that I could just work around the requirement itself. However, upstream had patches ready to update the httpx version but did not merge them, so I believe that requirement is there for a reason.

If you want to get it fixed, file an issue or open a pull request on GitHub.

EDIT: Wrong mention :P

yochananmarqos commented on 2021-09-08 14:08 (UTC)

@timschumi: You can get around it by relaxing the requirements. I'm having no issues with translations with Dialect.

Add this to a prepare() function:

  # Relax requirements
  sed -i 's/==/>=/g' googletrans.egg-info/requires.txt

timschumi commented on 2021-09-08 11:44 (UTC)

@SamLukeYes I can't do anything against the fact that googletrans requires an ancient version of httpx, that would have to be fixed upstream. All I can do is require that version of httpx at the package manager level.

SamLukeYes commented on 2021-09-08 02:38 (UTC)

pkg_resources.DistributionNotFound: The 'httpx==0.13.3' distribution was not found and is required by googletrans

yochananmarqos commented on 2020-12-31 17:47 (UTC)

@timschumi: Please make the following changes.

depends=('python-httpx' 'python-h2')
optdepends=('python-hyper: faster http networking')

See here about using hyper.