Package Details: python-googletrans 4.0.0rc1-1

Git Clone URL: https://aur.archlinux.org/python-googletrans.git (read-only, click to copy)
Package Base: python-googletrans
Description: Free Google Translate API for Python.
Upstream URL: https://github.com/ssut/py-googletrans
Licenses: MIT
Submitter: timschumi
Maintainer: timschumi
Last Packager: timschumi
Votes: 7
Popularity: 0.000064
First Submitted: 2019-10-03 12:02 (UTC)
Last Updated: 2021-11-22 12:06 (UTC)

Latest Comments

timschumi commented on 2021-09-27 22:00 (UTC)

@D3SOX: This is intentional. googletrans doesn't accept anything else than that specific version of httpx, and it's a hard requirement.

D3SOX commented on 2021-09-27 21:23 (UTC)

error: could not find all required packages:
    python-httpx=0.13.3 (wanted by: python-googletrans)

yochananmarqos commented on 2021-09-14 23:46 (UTC)

@rafaelff:

Does running sed on the requirement file work?

I don't know, does it? What's your use case? As I already said,

I'm having no issues with translations with Dialect.

timschumi commented on 2021-09-14 20:15 (UTC)

You could install an old version of python-httpx via the downgrade tool, the package is still available on the archive servers.

Other than that, using sed would probably work, at least if other users are to be believed.

rafaelff commented on 2021-09-14 20:03 (UTC)

Since this package relies on a unavailable dependency, is there any recommended workaround (except using pip, obviously) ? Does running sed on the requirement file work?

timschumi commented on 2021-09-08 14:40 (UTC) (edited on 2021-09-08 14:40 (UTC) by timschumi)

@yochananmarqos: I'm aware that I could just work around the requirement itself. However, upstream had patches ready to update the httpx version but did not merge them, so I believe that requirement is there for a reason.

If you want to get it fixed, file an issue or open a pull request on GitHub.

EDIT: Wrong mention :P

yochananmarqos commented on 2021-09-08 14:08 (UTC)

@timschumi: You can get around it by relaxing the requirements. I'm having no issues with translations with Dialect.

Add this to a prepare() function:

  # Relax requirements
  sed -i 's/==/>=/g' setup.py googletrans.egg-info/requires.txt

timschumi commented on 2021-09-08 11:44 (UTC)

@SamLukeYes I can't do anything against the fact that googletrans requires an ancient version of httpx, that would have to be fixed upstream. All I can do is require that version of httpx at the package manager level.

SamLukeYes commented on 2021-09-08 02:38 (UTC)

pkg_resources.DistributionNotFound: The 'httpx==0.13.3' distribution was not found and is required by googletrans

yochananmarqos commented on 2020-12-31 17:47 (UTC)

@timschumi: Please make the following changes.

depends=('python-httpx' 'python-h2')
makedepends=('python-setuptools')
optdepends=('python-hyper: faster http networking')

See here about using hyper.

fushinari commented on 2020-12-31 14:26 (UTC)

@yochananmarqos: yes, but seems there are issues with py-googletrans in specific (because http2=True is used in it). See: https://aur.archlinux.org/packages/dialect/#comment-781678 .

yochananmarqos commented on 2020-12-19 15:41 (UTC) (edited on 2020-12-31 17:33 (UTC) by yochananmarqos)

@fushinari: python-h2 is an optional dependency of python-httpcore which is a dependency of python-httpx.

fushinari commented on 2020-12-19 08:07 (UTC)

Please add python-h2 as a dependency because it seems py-googletrans is now forcing HTTP/2 support.

vivaeltopo commented on 2020-12-05 15:42 (UTC) (edited on 2020-12-05 15:46 (UTC) by vivaeltopo)

ty, I guess a probably working package is better than a not working package.

timschumi commented on 2020-12-05 15:22 (UTC)

I held off on updating since it was marked as a pre-release version. I'll update the package.

vivaeltopo commented on 2020-12-05 15:19 (UTC)

3.0.0 doesnt work anymore. Changing the pkgver to 3.1.0a0 allows to use a temporary fix

timschumi commented on 2020-12-02 12:34 (UTC)

Is that common procedure for Python packages? I have never seen an AUR python package bump its pkgrel whenever a new Python version is released.

Also, I don't see why you couldn't just rebuild the package.

fushinari commented on 2020-12-02 12:10 (UTC)

Python 3.9 is out for Arch. Pls up the pkgrel.

timschumi commented on 2020-10-06 10:58 (UTC)

Ah you were talking about building the package. I probably won't change the version declaration though because you'll have to downgrade the package manually anyways, no matter if its enforced when building or when enforced in the PKGBUILD.

If the package works fine with newer httpx versions, this is an upstream issue and you should ask them to make it a >=0.13.3.

PumpkinCheshire commented on 2020-10-05 15:01 (UTC)

I got this when using newer version: DistributionNotFound: The 'httpx==0.13.3' distribution was not found and is required by googletrans

Perhaps upgrading the httpx version will not cause any incompatibility, but an error will be reported due to the settings in setup.py when setting up the environment.

timschumi commented on 2020-10-05 13:25 (UTC)

Is there anything specific that is broken for you? The library works just fine for me (using httpx 0.14.0) when trying to replicate the examples from the readme.

PumpkinCheshire commented on 2020-10-05 12:57 (UTC)

It seem the dependencies required python-httpx==0.13.3 and that package just updated to 0.14, and this package stoped working. So could you please edit the denpendencies?

yochananmarqos commented on 2020-08-11 19:10 (UTC)

This only depends on python-httpx, see the setup.py. python-setuptools should be in makedepends().

timschumi commented on 2020-07-20 13:28 (UTC)

@privong Indeed, I haven't noticed that the dependencies have been updated. Should be fine now.

privong commented on 2020-07-20 13:12 (UTC)

I think this package should have python-httpcore and python-httpx as dependencies. The import fails without those two packages.