Package Details: python-gradio 4.19.2-1

Git Clone URL: https://aur.archlinux.org/python-gradio.git (read-only, click to copy)
Package Base: python-gradio
Description: Create UIs for your machine learning model in Python in 3 minutes
Upstream URL: https://github.com/gradio-app/gradio
Licenses: custom
Submitter: huyz
Maintainer: huyz
Last Packager: huyz
Votes: 1
Popularity: 0.002906
First Submitted: 2022-10-21 14:20 (UTC)
Last Updated: 2024-03-01 12:34 (UTC)

Latest Comments

Cr0c0d1Le commented on 2023-12-11 17:27 (UTC) (edited on 2023-12-11 17:28 (UTC) by Cr0c0d1Le)

Installtion failed with error below:

error: can't build python-gradio-4.8.0-1, deps not satisfied: python-gradio-client

error: can't build python-gradio-client-0.7.1-1, deps not satisfied: python-gradio

It seems like a circular dependency problem?

niva commented on 2023-04-30 11:35 (UTC) (edited on 2023-04-30 11:36 (UTC) by niva)

Installation stops with:

ERR_PNPM_FROZEN_LOCKFILE_WITH_OUTDATED_LOCKFILE  Cannot perform a frozen installation because the version of the lockfile is incompatible with this version of pnpm

:(

Henry-ZHR commented on 2023-04-22 08:37 (UTC)

Missing dependency python-aiofiles

Bluebomber182 commented on 2023-03-13 21:47 (UTC) (edited on 2023-03-13 21:48 (UTC) by Bluebomber182)

I got this error message

--- JS stacktrace --->

FATAL ERROR: Reached heap limit Allocation failed - JavaScript heap out of memory
 1: 0x7fee02083d0d node::Abort() [/usr/bin/../lib/libnode.so.111]
 2: 0x7fee01d68cdb node::OOMErrorHandler(char const*, v8::OOMDetails const&) [/usr/bin/../lib/libnode.so.111]
 3: 0x7fee02447f64 v8::Utils::ReportOOMFailure(v8::internal::Isolate*, char const*, v8::OOMDetails const&) [/usr/bin/../lib/libnode.so.111]
 4: 0x7fee02448358 v8::internal::V8::FatalProcessOutOfMemory(v8::internal::Isolate*, char const*, v8::OOMDetails const&) [/usr/bin/../lib/libnode.so.111]
 5: 0x7fee0263aa3c  [/usr/bin/../lib/libnode.so.111]
 6: 0x7fee02655224 v8::internal::Heap::CollectGarbage(v8::internal::AllocationSpace, v8::internal::GarbageCollectionReason, v8::GCCallbackFlags) [/usr/bin/../lib/libnode.so.111]
 7: 0x7fee02655791 v8::internal::Heap::CollectAllGarbage(int, v8::internal::GarbageCollectionReason, v8::GCCallbackFlags) [/usr/bin/../lib/libnode.so.111]
 8: 0x7fee025d39ed v8::internal::StackGuard::HandleInterrupts() [/usr/bin/../lib/libnode.so.111]
 9: 0x7fee029f63a9 v8::internal::Runtime_StackGuard(int, unsigned long*, v8::internal::Isolate*) [/usr/bin/../lib/libnode.so.111]
10: 0x7fee023433f9  [/usr/bin/../lib/libnode.so.111]
/home/user/Downloads/python-gradio/src/gradio-3.20.0/ui/packages/app:
 ERR_PNPM_RECURSIVE_RUN_FIRST_FAIL  @gradio/app@1.0.0 build:local: `vite build --mode production:local --emptyOutDir "--emptyOutDir"`
Command failed with signal "SIGABRT"
 ELIFECYCLE  Command failed.
./scripts/build_frontend.sh: line 11: 28491 Aborted                 pnpm build
==> ERROR: A failure occurred in build().
    Aborting...

So I added this line to the .bashrc file and then I restarted the terminal.

export NODE_OPTIONS="--max-old-space-size=8192"

Then I had to install the pluggy module

python -m pip install pluggy