Package Details: python-gtts 2.5.1-1

Git Clone URL: https://aur.archlinux.org/python-gtts.git (read-only, click to copy)
Package Base: python-gtts
Description: Python library and CLI tool to interface with Google Translate's text-to-speech API
Upstream URL: https://github.com/pndurette/gTTS
Licenses: MIT
Submitter: tembleking
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 19
Popularity: 0.98
First Submitted: 2017-02-03 15:51 (UTC)
Last Updated: 2024-01-29 15:12 (UTC)

Latest Comments

1 2 Next › Last »

system7 commented on 2023-02-05 09:53 (UTC)

Hello,

I have a problem w/ the install. What have I wrong?

* Getting build dependencies for wheel...
/usr/lib/python3.10/site-packages/setuptools/config/pyprojecttoml.py:114: _BetaConfiguration: Support for `[tool.setuptools]` in `pyproject.toml` is still *beta*.
  warnings.warn(msg, _BetaConfiguration)
validate_pyproject.api.load_builtin_plugin defines `tool.distutils` schema
validate_pyproject.api.load_builtin_plugin defines `tool.setuptools` schema
running egg_info
creating gTTS.egg-info
writing gTTS.egg-info/PKG-INFO
writing dependency_links to gTTS.egg-info/dependency_links.txt
writing entry points to gTTS.egg-info/entry_points.txt
writing requirements to gTTS.egg-info/requires.txt
writing top-level names to gTTS.egg-info/top_level.txt
writing manifest file 'gTTS.egg-info/SOURCES.txt'
reading manifest file 'gTTS.egg-info/SOURCES.txt'
adding license file 'LICENSE'
writing manifest file 'gTTS.egg-info/SOURCES.txt'

ERROR Missing dependencies:
    setuptools>=61
    jaraco.text -> inflect -> pydantic>=1.9.1 -> typing-extensions>=4.2.0
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: python-gtts

kIERO commented on 2022-11-30 15:24 (UTC)

new PKBUILD using (PEP 517) https://wiki.archlinux.org/title/Python_package_guidelines#Installation_methods

# Maintainer: Jonian Guveli <https://github.com/jonian/>
pkgname=python-gtts
pkgver=2.3.0
pkgrel=1
pkgdesc="Module and command line utility to save spoken text to mp3 via the Google Text to Speech (TTS) API "
arch=('any')
url="https://github.com/pndurette/gTTS"
license=('MIT')
depends=('python-six' 'python-click' 'python-requests')
makedepends=('python-build' 'python-installer' 'python-wheel')
source=("https://github.com/pndurette/gTTS/archive/v${pkgver}.tar.gz")
md5sums=('ce04a01d71227c38f2d32d57b1a080ea')

build() {
  cd "$srcdir/gTTS-$pkgver"
  #python setup.py build
  python -m build --wheel --no-isolation
}

package() {
  cd "$srcdir/gTTS-$pkgver"
  #python setup.py install --root="$pkgdir" --optimize=1
  python -m installer --destdir="$pkgdir" dist/*.whl
}

yochananmarqos commented on 2021-06-18 14:18 (UTC)

This no longer requires python-gtts-token as it's deprecated.

yochananmarqos commented on 2020-11-15 19:02 (UTC)

2.2.1 is now released and python-beautifulsoup4 is no longer a dependency.

PedroHLC commented on 2020-11-04 15:30 (UTC)

I can't build this one, it loops with this message:

WARNING: The pip package is not available, falling back to EasyInstall for handling setup_requires/test_requires; this is deprecated and will be removed in a future version.

rkcf commented on 2019-05-20 17:36 (UTC)

Missing dependencies for click, bs4, and six

https://github.com/pndurette/gTTS/blob/master/setup.cfg

Cysioland commented on 2019-05-16 09:25 (UTC)

pkg_resources.DistributionNotFound: The 'bs4' distribution was not found and is required by gTTS

Cysioland commented on 2019-05-16 09:25 (UTC)

pkg_resources.DistributionNotFound: The 'bs4' distribution was not found and is required by gTTS

kamelie1706 commented on 2019-01-05 22:46 (UTC)

When trying to install python-gtts-token, it could not find it.

ratzfatz commented on 2018-10-10 11:14 (UTC)

Is there a solution for this problem?

403 Client Error: Forbidden for url: http://translate.google.com/translate_tts?textlen=12&idx=0&q=%E4%B8%80%E6%9D%A1%E8%A1%97%E9%81%93&tl=zh&client=t&total=1&ie=UTF-8

Regards,

Michael