Package Details: python-humanfriendly 4.18-2

Git Clone URL: https://aur.archlinux.org/python-humanfriendly.git (read-only, click to copy)
Package Base: python-humanfriendly
Description: Human friendly input/output in Python
Upstream URL: https://github.com/xolox/python-humanfriendly
Licenses: MIT
Submitter: maikoool
Maintainer: maikoool
Last Packager: maikoool
Votes: 11
Popularity: 0.65
First Submitted: 2016-09-16 14:15
Last Updated: 2019-11-18 01:36

Latest Comments

maikoool commented on 2019-11-25 11:39

@hrehfeld I cannot reproduce your error.

Please clean your build environment and try again. Most notably: you should get rid of the '==> WARNING: Using existing $srcdir/ tree'

hrehfeld commented on 2019-11-25 11:35

==> Making package: python-humanfriendly 4.18-2 (Mon 25 Nov 2019 12:07:43 PM CET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Entering fakeroot environment...
==> Starting package()...
Traceback (most recent call last):
  File "setup.py", line 29, in <module>
    from setuptools import find_packages, setup
  File "/usr/lib/python3.8/site-packages/setuptools/__init__.py", line 20, in <module>
    from setuptools.dist import Distribution, Feature
  File "/usr/lib/python3.8/site-packages/setuptools/dist.py", line 30, in <module>
    import ordered_set
ModuleNotFoundError: No module named 'ordered_set'
==> ERROR: A failure occurred in package().
    Aborting...
Error making: python-humanfriendly

djmattyg007 commented on 2019-11-17 01:04

Could you please bump the pkgrel to force a rebuild for python3.8?

polyzen commented on 2019-01-06 03:20

Please prefix the source with python-humanfriendly, eg.:

source=("$pkgname-$pkgver::<https://github.com/xolox/python-humanfriendly/archive/>$pkgver.tar.gz")

or

source=("<https://github.com/xolox/python-humanfriendly/archive/>$pkgver/python-coloredlogs-$pkgver.tar.gz")

maikoool commented on 2018-06-08 10:40

@jeremejevs It seems I forgot to update .SRCINFO.

Fixed now.

jeremejevs commented on 2018-06-08 10:39

I don't get it, why does PKGBUILD have 4.12.1 in it, but the package shows up as 4.4.1? Was it rolled back or something?

djmattyg007 commented on 2017-01-07 10:22

Could you please bump the pkgrel to force a rebuild for python3.6

djmattyg007 commented on 2016-12-22 05:40

python-setuptools needs to be added to the makedepends array.