Package Details: python-icalendar 3.10-1

Git Clone URL: https://aur.archlinux.org/python-icalendar.git (read-only)
Package Base: python-icalendar
Description: A parser/generator of iCalendar files (RFC 2445)
Upstream URL: http://pypi.python.org/pypi/icalendar/
Licenses: GPL
Conflicts: python-icalendar-git
Submitter: onny
Maintainer: Sirat18
Last Packager: Sirat18
Votes: 19
Popularity: 2.705821
First Submitted: 2013-08-31 20:03
Last Updated: 2016-05-31 10:26

Dependencies (4)

Required by (9)

Sources (1)

Latest Comments

olebowle commented on 2015-10-02 15:31

Please don't forget to run mksrcinfo and add the modified .SRCINFO prior to committing. Right now this pages shows v3.9.0, whereas in git you have v3.9.1.

Furthermore bumping pkgrel is needed to force python 3.5 rebuild.

hobarrera commented on 2014-04-08 03:46

python-dateutil should be included in depends.

alemedeiros commented on 2014-01-30 17:42

got a missing library error while importing (dateutil), I think you should add python-dateutil to the dependencies.

onny commented on 2014-01-23 18:20

@minus: new version, should be fixed now!

minus commented on 2014-01-22 19:25

Doesn't seem to work, I get this when trying to import:

File "/usr/lib/python3.3/site-packages/icalendar/parser.py", line 25
return text.replace('\N', '\n')\
^
SyntaxError: (unicode error) 'unicodeescape' codec can't decode bytes in position 0-1: malformed \N character escape

And more – seemingly Python 2→3 related stuff – when i fix that. Does this really work with Python 3?