Package Details: python-imageio 2.33.1-1

Git Clone URL: https://aur.archlinux.org/python-imageio.git (read-only, click to copy)
Package Base: python-imageio
Description: a Python library that provides an easy interface to read and write a wide range of image data
Upstream URL: https://github.com/imageio/imageio
Licenses: BSD
Submitter: Francois_B
Maintainer: leomao
Last Packager: leomao
Votes: 31
Popularity: 1.12
First Submitted: 2015-07-08 00:42 (UTC)
Last Updated: 2024-01-05 10:47 (UTC)

Latest Comments

1 2 3 Next › Last »

leomao commented on 2023-12-02 13:51 (UTC)

Thanks for the information.

  • Added: python-tifffile, python-av.
  • Removed: avbin.

I think freeimage is still usable. Please correct me if it is not the case.

MarsSeed commented on 2023-12-02 12:37 (UTC) (edited on 2023-12-02 12:38 (UTC) by MarsSeed)

Hi,

Please kindly remove the following unneeded optdepends (cannot be used anymore by this module):

  • avbin
  • freeimage

However, I suggest that you can add a new optdepend:

Source of the information: README.md/Dependencies.

leomao commented on 2023-10-14 04:18 (UTC)

Thanks for the information. I updated the PKGBUILD.

TrialnError commented on 2023-10-13 16:56 (UTC)

python-wheel is also missing as a makedep for using the wheel way of creating python packages.

petronny commented on 2023-10-13 14:21 (UTC)

python-setuptools is needed during the build.

ModuleNotFoundError: No module named 'setuptools'

ERROR Backend 'setuptools.build_meta:__legacy__' is not available.
==> ERROR: A failure occurred in build().

https://github.com/arch4edu/cactus/actions/runs/6508416259/job/17677731087

jwh commented on 2022-07-23 23:57 (UTC)

Could you add aarch64? Hate to ask but makepkg still doesn't have the ability to ignore arch in makepkg.conf :(

31415926 commented on 2022-02-03 00:33 (UTC)

PKGBUILD for 2.14.1: https://pastebin.com/Xj3i8hQu diff of PKGBUILD for 2.14.0 with 2.14.1: https://pastebin.com/4aDgwe6L

m-pilia commented on 2021-04-05 11:24 (UTC)

Hi! I splitted python-simpleitk out of the simpleitk package. Can you please update the dependency to python-simpleitk?

djmattyg007 commented on 2021-01-03 02:53 (UTC)

Could you please bump the pkgrel to force a rebuild for python3.9?