Package Details: python-imapclient 2.2.0-1

Git Clone URL: https://aur.archlinux.org/python-imapclient.git (read-only, click to copy)
Package Base: python-imapclient
Description: An easy-to-use, Pythonic and complete IMAP client library with no dependencies outside the Python standard library
Upstream URL: https://github.com/mjs/imapclient/
Licenses: BSD
Submitter: zeppelinlg
Maintainer: DarioP
Last Packager: DarioP
Votes: 5
Popularity: 0.000001
First Submitted: 2013-07-09 14:43 (UTC)
Last Updated: 2021-03-22 10:45 (UTC)

Latest Comments

flacks commented on 2018-08-23 21:30 (UTC)

Hi, for version 2.0.0, line 42 of setup.py shows that python-six is a required dependency.

ryukinix commented on 2017-07-20 13:31 (UTC)

We need delete the "mock==1.3.0" before build the package. I suggest to a easy hotfix just call this between cd srcdir (line 20) and setup install.py (line 21): sed "s/\s'mock==1.3.0'//" -i setup.py This will delete the broken dependency and produce a healthy package as @kseistrup said. A updated version of the PKGBUILD can be found here: https://gist.github.com/632843e7315e6ba34acee9e3fddbf2fd

kseistrup commented on 2016-08-20 06:24 (UTC)

The package has “'mock==1.3.0'” in it's main_deps. If the version requirement for mock is removed, makepkg will run without any problems and produce a healthy package.

kseistrup commented on 2016-08-18 10:47 (UTC)

When running "makepkg -s": SystemExit: error in setup command: Error parsing /tmp/user/1000/easy_install-d0_z_lu2/mock-1.3.0/setup.cfg: ImportError: No module named 'monolithic' and distutils.errors.DistutilsError: Setup script exited with error in setup command: Error parsing /tmp/user/1000/easy_install-d0_z_lu2/mock-1.3.0/setup.cfg: ImportError: No module named 'monolithic'

fauxmight commented on 2016-08-03 04:22 (UTC)

Version 1.0.1 is available now. I've packaged python-backports.ssl (which is required for newer versions of python-imapclient) and added it to AUR as well Please find new PKGBUILD here: https://github.com/fauxmight/python-imapclient