Package Details: python-inputs 0.5-4

Git Clone URL: https://aur.archlinux.org/python-inputs.git (read-only, click to copy)
Package Base: python-inputs
Description: Cross-platform Python support for keyboards, mice and gamepads
Upstream URL: https://github.com/zeth/inputs
Licenses: BSD-3-Clause
Submitter: majorx234
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 22
Popularity: 3.24
First Submitted: 2017-10-01 00:49 (UTC)
Last Updated: 2024-01-21 18:38 (UTC)

Latest Comments

yochananmarqos commented on 2024-01-21 20:53 (UTC)

@xiota: Don't you dare spam this comment on all my packages. I've already answered you.

xiota commented on 2024-01-21 20:51 (UTC)

pkgrel needs to be bumped. Changing license string changes package.

loathingkernel commented on 2023-02-08 15:29 (UTC)

Thanks, one more suggestion. Rename the file in the sources array to something unambiguous (v5.0.<ext> might conflict with other packages) as explained here https://wiki.archlinux.org/title/PKGBUILD#Sources. $pkgname-$pkgver.<ext> is generally good enough

majorx234 commented on 2023-02-04 00:27 (UTC)

@loathingkernel: should be fixed now. thx for suggestions

loathingkernel commented on 2023-02-03 14:17 (UTC) (edited on 2023-02-03 14:17 (UTC) by loathingkernel)

The pkgbuild is stupidly broken, the pkgver doesn't exist (why the hell is it overriden by the _tag? What is the reasoning for the discrepancy in the version numbers?)

In addition to the above the PKGBUILD is missing a patch that makes it un-buildable.

I am attaching a link to a working script https://github.com/loathingKernel/PKGBUILDs/tree/master/aur/python-inputs