Package Details: python-jenkins-job-builder 3.12.0-4

Git Clone URL: https://aur.archlinux.org/python-jenkins-job-builder.git (read-only, click to copy)
Package Base: python-jenkins-job-builder
Description: Takes simple descriptions of Jenkins jobs in YAML or JSON format and uses them to configure Jenkins
Upstream URL: https://jenkins-job-builder.readthedocs.io/en/latest/
Licenses: Apache
Submitter: Synthead
Maintainer: jonathanio
Last Packager: jonathanio
Votes: 3
Popularity: 0.000000
First Submitted: 2016-04-28 01:28 (UTC)
Last Updated: 2022-04-12 13:40 (UTC)

Latest Comments

1 2 Next › Last »

jonathanio commented on 2022-04-08 09:24 (UTC)

I've updated the package to support python-yaml v6 or greater. In the end, I didn't need to update the requirements.txt as not used during the build process.

pespin commented on 2022-04-07 16:24 (UTC)

Regarding the python-yaml<6 requirement (archlinux now ships with python-yaml 6), I tested building last python-jenkins-job-builder version 3.12.0 and it still has the same problem. When I run it, I get: pkg_resources.VersionConflict: (PyYAML 6.0 (/usr/lib/python3.10/site-packages), Requirement.parse('PyYAML<6,>=3.10.0'))

However, after modifying /usr/lib/python3.10/site-packages/jenkins_job_builder-3.12.0-py3.10.egg-info/requires.txt to check for "<7", I can use it without problem.

It seems upstream blocks the requirements explicitly for some unknown reason: https://opendev.org/jjb/jenkins-job-builder/commit/23079af77770f736ce340eebabfeb4714fa25d89

The bug is open upstream here: https://storyboard.openstack.org/#!/story/2009723

It seems simply having a patch dropping ",<6" in jenkins-job-builder.git/requirements.txt would do the trick.

pespin commented on 2022-02-24 22:05 (UTC)

Since today, I had to remove this package you be able to upgrade (yay -Syu), due to: error: failed to prepare transaction (could not satisfy dependencies) :: installing python-yaml (6.0-1) breaks dependency 'python-yaml<6' required by python-jenkins-job-builde

After upgrading, I tried installing, it errors: $ yay -S python-jenkins-job-builder -> Could not find all required packages: python-yaml<6 (Wanted by: python-jenkins-job-builder)

iamazat commented on 2018-08-09 14:06 (UTC)

@ilpianista could you please bump package version to 2.2.1-1?

InfernoZeus commented on 2017-05-16 18:47 (UTC)

I emailed the openstack-infra mailing list for clarification, and it looks like they still consider it beta: http://lists.openstack.org/pipermail/openstack-infra/2017-May/005346.html

InfernoZeus commented on 2017-05-15 14:27 (UTC)

PyPi already has 2.0.0.0b2, so it's clearly considered stable despite the version name.

ilpianista commented on 2017-05-15 13:49 (UTC) (edited on 2017-05-15 13:50 (UTC) by ilpianista)

@jtyr No, I'll wait until final is released.

jtyr commented on 2017-01-05 15:57 (UTC)

Please could you upgrade this package to the latest release 2.0.0.0b1?

jonathanio commented on 2016-11-23 16:56 (UTC)

@ilpianista Thank you! :)

ilpianista commented on 2016-11-23 16:32 (UTC)

@jonathanio Adopted. I'll update it this evening.