Package Details: python-language-server 0.15.1-2

Git Clone URL: (read-only)
Package Base: python-language-server
Description: An implementation of the Language Server Protocol for Python
Upstream URL:
Licenses: MIT
Conflicts: python-language-server, python-language-server-git
Submitter: fenuks
Maintainer: fenuks
Last Packager: fenuks
Votes: 6
Popularity: 1.792999
First Submitted: 2017-08-13 00:26
Last Updated: 2018-03-03 23:17

Latest Comments

hexchain commented on 2018-03-03 15:03

Checksums seem incorrect.

Looking from here:



zerox2a commented on 2017-12-26 20:27

Fails to install because of md5 check

panashe commented on 2017-11-12 15:43

python-rope is required

BuZZ-dEE commented on 2017-11-06 22:35

The package "python-mccabe" is required.

Traceback (most recent call last):
File "/usr/bin/pyls", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.6/site-packages/pkg_resources/", line 3142, in <module>
File "/usr/lib/python3.6/site-packages/pkg_resources/", line 3126, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.6/site-packages/pkg_resources/", line 3155, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.6/site-packages/pkg_resources/", line 664, in _build_master
File "/usr/lib/python3.6/site-packages/pkg_resources/", line 981, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.6/site-packages/pkg_resources/", line 867, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'mccabe' distribution was not found and is required by python-language-server

coolmast commented on 2017-10-06 06:43

The hashes are out of date.
Thanks for maintaining this package :-)

fenuks commented on 2017-09-14 21:55


Thank you for pointing this out. It's not listed as dependency in requirements.txt, and I already had it installed.

mtorromeo commented on 2017-09-14 09:23

pkg_resources.DistributionNotFound: The 'pluggy' distribution was not found and is required by python-language-server

fenuks commented on 2017-09-05 19:45


I've updated PKGBUILD. File must have changed, last time I built the package, they were correct.

Thank you for letting me know of updates, that's very helpful! :)

wbthomason commented on 2017-09-05 16:35

The hashes for the sources are out of date; they should be this:


By the way, thanks for being so prompt with version updates!