Package Details: python-librtmp 0.3.0-1

Git Clone URL: (read-only)
Package Base: python-librtmp
Description: Python interface to librtmp (python3 version)
Upstream URL:
Licenses: custom: Simplified BSD
Submitter: carstene1ns
Maintainer: carstene1ns
Last Packager: carstene1ns
Votes: 13
Popularity: 0.510899
First Submitted: 2014-01-06 20:48
Last Updated: 2015-07-08 03:28

Latest Comments

antena commented on 2015-04-28 19:38

@carstene1ns: bah, you are right. A total brainfart on my part, I forgot I had to customize it for a script a month or so ago. And I was so sure I checked from all angles. Works as intended. Thanks for the help and sorry to take your time for nothing.

carstene1ns commented on 2015-04-28 19:21

@antena: It seems like your default python version is 2. Arch sets version 3 for '/usr/bin/python' and this package assumes defaults.
If you changed this intentionally, you should expect problems with all AUR packages depending on python 3.
You can check with this commands:
$ which python
$ file /usr/bin/python

antena commented on 2015-04-28 18:56

error: failed to commit transaction (conflicting files)
/usr/lib/python2.7/site-packages/librtmp/ exists in both 'python-librtmp' and 'python2-librtmp'
/usr/lib/python2.7/site-packages/librtmp/__init__.pyc exists in both 'python-librtmp' and 'python2-librtmp'
/usr/lib/python2.7/site-packages/librtmp/__init__.pyo exists in both 'python-librtmp' and 'python2-librtmp'
Errors occurred, no packages were upgraded.


A lot of files (all of them?) are listed as existing in both.

This happens on python-librtmp, as well as python2-librtmp, which I had both installed before. After uninstalling python2-librtmp, the error does not go away.


carstene1ns commented on 2014-01-11 08:53

You might need this library for livestreamer (

carstene1ns commented on 2014-01-06 20:50

This is the somewhat stable version, for the development snapshot see [1].