Package Details: python-llvmlite 0.30.0-1

Git Clone URL: https://aur.archlinux.org/python-llvmlite.git (read-only)
Package Base: python-llvmlite
Description: Lightweight LLVM python binding for writing JIT compilers
Upstream URL: https://github.com/numba/llvmlite
Licenses: BSD
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 23
Popularity: 0.971982
First Submitted: 2014-12-29 17:23
Last Updated: 2019-10-11 08:41

Latest Comments

1 2 3 4 5 6 ... Next › Last »

a821 commented on 2019-10-13 10:51

I modified the PKGBUILD using krachyon's patch to test it and so far I confirm that it works. In case someone else wants to test it, here is the my PKGBUILD patch (copy krachyon's patch below and save it as llvm9.patch). @mschu feel free to use/change.

diff --git a/PKGBUILD b/PKGBUILD
index 82adbea..bc24767 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,17 @@ pkgdesc="Lightweight LLVM python binding for writing JIT compilers"
 url="https://github.com/numba/llvmlite"
 arch=('i686' 'x86_64')
 license=('BSD')
-depends=('python' 'llvm-libs>=7.0.0' 'llvm-libs<8.1.0')
-makedepends=('cython' 'llvm>=7.0.0' 'llvm<8.1.0')
-source=("https://github.com/numba/llvmlite/archive/v$pkgver.tar.gz")
-sha256sums=('07b72dfdd8e6e5bc718fc7cd00517b94bf00caf29b387605adb0779c5c63dc28')
+depends=('python' 'llvm-libs>=7.0.0' 'llvm-libs<9.1.0')
+makedepends=('cython' 'llvm>=7.0.0' 'llvm<9.1.0')
+source=("https://github.com/numba/llvmlite/archive/v$pkgver.tar.gz"
+        "llvm9.patch")
+sha256sums=('07b72dfdd8e6e5bc718fc7cd00517b94bf00caf29b387605adb0779c5c63dc28'
+            '271acc57e6b40d00a3089badbc122a9d1505295936f6b042254057f3caf0c102')
+
+prepare() {
+  cd "$srcdir/llvmlite-$pkgver/ffi"
+  patch -p0 < ../../llvm9.patch
+}

 build() {
   cd "$srcdir/llvmlite-$pkgver"

mschu commented on 2019-10-12 17:06

I'd be happy to patch @krachyon's suggestion if people can confirm there are no issues with it.

krachyon commented on 2019-10-11 11:06

Another workaround that seems to sort-of work: Just editing ffi/build.py to accept version 9.0 makes the package build again. Not sure if the build is subtly broken, but running some numba examples at least does not crash horribly...

--- build.py_orig       2019-10-11 13:02:12.914644374 +0200
+++ build.py    2019-10-11 13:03:39.048201119 +0200
@@ -109,7 +109,7 @@

     out = out.decode('latin1')
     print(out)
-    if not (out.startswith('8.0.') or out.startswith('7.0.')
+    if not out.startswith('9.0.') or (out.startswith('8.0.') or out.startswith('7.0.')
             or out.startswith('7.1.')):
         msg = (
             "Building llvmlite requires LLVM 7.0+ Be sure to "

julian.carpenter commented on 2019-10-11 09:38

just as information. The unofficial archlinuxcn repo has llvm==8 as 'llvm-julia' available.

just for those who have this repo in their pacman.conf.

mschu commented on 2019-10-11 08:32

llvmlite does not yet support llvm>=9.0, there is no llvm=8.x package in the AUR yet, and llvmlite still checks the llvm version (https://github.com/numba/llvmlite/issues/507).

For now, the only solution is to disable llvm updates until any one of these issues is fixed.

languitar commented on 2019-10-11 08:24

The latest package updates in the official repos make this package unusable:

error: failed to prepare transaction (could not satisfy dependencies) :: installing llvm-libs (9.0.0-3) breaks dependency 'llvm-libs<8.1.0' required by python-llvmlite

bogeyman2007 commented on 2019-06-23 04:37

When I reinstall LLVM 8 then recompile python-llvmlite, I can get the same result of pacman -Qo as yours. But, the same error still happen when I run numba. I think the issue might be in python-numba package so I post a question there https://aur.archlinux.org/packages/python-numba/#comment-698043.

mschu commented on 2019-06-11 20:21

I can not reproduce this. The file should be there, owned by python-llvmlite:

pacman -Qo /usr/lib/python3.7/site-packages/llvmlite/binding/libllvmlite.so
/usr/lib/python3.7/site-packages/llvmlite/binding/libllvmlite.so is owned by python-llvmlite 0.29.0-1

bogeyman2007 commented on 2019-06-10 08:57

I have recompile python-llvmlite but still got the same error. Here is the complete error message.


Traceback (most recent call last):
  File "fast_functions.py", line 6, in <module>
    import numba
  File "/usr/lib/python3.7/site-packages/numba/__init__.py", line 11, in <module>
    from . import config, errors, _runtests as runtests, types
  File "/usr/lib/python3.7/site-packages/numba/config.py", line 18, in <module>
    import llvmlite.binding as ll
  File "/usr/lib/python3.7/site-packages/llvmlite/binding/__init__.py", line 6, in <module>
    from .dylib import *
  File "/usr/lib/python3.7/site-packages/llvmlite/binding/dylib.py", line 4, in <module>
    from . import ffi
  File "/usr/lib/python3.7/site-packages/llvmlite/binding/ffi.py", line 154, in <module>
    raise OSError("Could not load shared object file: {}".format(_lib_name))
OSError: Could not load shared object file: libllvmlite.so

mschu commented on 2019-06-04 12:16

You need to compile python-llvmlite after upgrading llvm and llvm-libs.

Otherwise, you link to the old llvm-libs library, which no longer exists after your upgrade to llvm=8.