Package Details: python-llvmlite 0.28.0-2

Git Clone URL: https://aur.archlinux.org/python-llvmlite.git (read-only)
Package Base: python-llvmlite
Description: Lightweight LLVM python binding for writing JIT compilers
Upstream URL: https://github.com/numba/llvmlite
Licenses: BSD
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 21
Popularity: 0.419446
First Submitted: 2014-12-29 17:23
Last Updated: 2019-04-01 10:14

Pinned Comments

mschu commented on 2019-05-21 09:47

Until 0.29.0 is out, you need 'python-llvmlite-git' to make it work with current llvm=7.1.0

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

Cbhihe commented on 2019-03-31 15:49

Upgrading to llvm v8.0.0-1 broke python-llvmlite and as a consequence python-numba.

Judging by @mschu's 2018-10-02_12:36 comments below. Can someone confirm that the cop-out is to either revert to extra/llvm7 (currently at v7.0.1-1) from v8.0.0-1 or wait for llvm upgrades until python-llvmlite and python-numba have caught up ?

EvilxFish commented on 2019-03-31 13:02

The package wants llvm < 7.1.0 but llvm is now 8.0.0, Attempting to install with yay gives the following error:

==> Error: Could not find all required packages: llvm<7.1.0 (Wanted by: python-llvmlite)

op3 commented on 2019-01-23 16:08

@jeancf: The hash of v0.27.0.tar.gz changed, make sure to delete the old file and start with a clean build directory.

jeancf commented on 2019-01-10 08:29

Trying to upgrade to 0.27.0-2:

==> Validating source files with sha256sums... v0.27.0.tar.gz ... FAILED ==> ERROR: One or more files did not pass the validity check!

amos commented on 2018-12-24 17:53

I'm getting a different sha256: cb065c00e93d741ba984c0df74ab0f804a5a06a1f9dc4ef8b01756f320827255

a821 commented on 2018-12-01 09:37

Thanks for updating, but the PKGBUILD doesn't work as it stands. To make it work set depends=('python' 'llvm6-libs') and makedepends=('cython' 'llvm6').

flying-sheep commented on 2018-11-14 12:32

not anymore. commit 499a6aba18ab6c4d11ae279604d4a62454cfa8d4 still has it, but they backed out due to bugs.

On your own risk, you could add #commit=... to the git URL and try with that

petronny commented on 2018-10-28 02:58

v0.26.0dev0 has been released and added support for llvm 7.

alleut commented on 2018-10-08 16:31

It doesn't, so options are (1) they fix their PKGBUILD

They won't:

https://bugs.archlinux.org/task/60346?string=llvm6&project=1&search_name=&type%5B0%5D=&sev%5B0%5D=&pri%5B0%5D=&due%5B0%5D=&reported%5B0%5D=&cat%5B0%5D=&status%5B0%5D=closed&percent%5B0%5D=&opened=&dev=&closed=&duedatefrom=&duedateto=&changedfrom=&changedto=&openedfrom=&openedto=&closedfrom=&closedto=

mschu commented on 2018-10-02 12:36

You see the error because the current version of llvmlite only supports llvm<6.1.0. See here: https://github.com/numba/llvmlite#compatibility

However, Arch can still upgrade llvm to a newer version that's not supported by llvm.

Solution should be to install the package extra/llvm6, which (in my opinion) should include the field provides=('llvm=6.0.1').

It doesn't, so options are (1) they fix their PKGBUILD, (2) I update this package to depend on llvm6 instead of llvm [*], or (3) you edit the PKGBUILD yourself when building the package.

[*] I don't like this option, because everyone that uses llvmlite would need to have 2 versions of llvm installed, and repeat this with every upgrade. It's cleaner to postpone llvm upgrades until llvmlite has caught up.