Package Details: python-llvmlite 0.30.0-1

Git Clone URL: https://aur.archlinux.org/python-llvmlite.git (read-only)
Package Base: python-llvmlite
Description: Lightweight LLVM python binding for writing JIT compilers
Upstream URL: https://github.com/numba/llvmlite
Licenses: BSD
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 24
Popularity: 1.32
First Submitted: 2014-12-29 17:23
Last Updated: 2019-10-11 08:41

Pinned Comments

mschu commented on 2019-10-27 15:03

Can anyone confirm if numba works for them with llvmlite patched like below?

I did a clean build for llvmlite+numba and "from numba import jit" gives an llvm error.

For now, the only workaround seems to not update & add in /etc/pacman.conf IgnorePkg = llvm llvm-libs

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

a821 commented on 2019-04-02 05:33

@Cbhihe check the wiki. Or install clean-chroot-manager.

The TL;DR version is install devtools and then

sudo mkarchroot $CHROOT/root base-devel
makechrootpkg -c -r $CHROOT

you can pass the option -I to makechrootpkg to add packages that are dependencies and not in the official repos. Necessary for python-numba

mschu commented on 2019-04-01 10:15

Working now with llvm7{,-libs} packages

Easiest way to install is to temporarily remote llvm>=8 (using -Rdd), install llvm7 and llvm7-libs, and install this package.

Cbhihe commented on 2019-04-01 08:06

I have chroot'ed before but only when installing Arch from scratch. So I'm not familiar with building stuff (e.g. python-llvmlite and python-numba) "in a clean chroot". Do you care to share steps or a pointer to them ?

a821 commented on 2019-03-31 21:44

Because the system upgrade failed in my system, what I first uninstalled python-llvmlite and python-numba before doing pacman -Syu.

After that, I replaced the depends makedepends by these lines in the PKGBUILD

depends=('python' 'llvm7-libs')
makedepends=('cython' 'llvm7')

Finally, I built python-llvmlite and python-numba in a clean chroot. Note that llvm7 is only needed for compiling. For running, llvm7-libs is enough (as far as I can tell from my testing). And llvm7-libs can live with llvm-libs.

Cbhihe commented on 2019-03-31 21:05

@op3: problem being that unless you somehow isolate one from the other in yr box, you cannot install llvm and llvm7 in parallel. If you try pacman'ing yr way to that, you get:
:: llvm7 and llvm are in conflict. Remove llvm?

How do you suggest one should install those two in parallel ?

op3 commented on 2019-03-31 20:49

I don't like this option, because everyone that uses llvmlite would need to have 2 versions of llvm installed, and repeat this with every upgrade. It's cleaner to postpone llvm upgrades until llvmlite has caught up.

I don’t think this is a clean solution at all. Arch Linux does not support partial upgrades, so by not updating the llvm dependency to the proper version, you are also forced to not upgrade any package that directly or indirectly depends on llvm itself. For example, mesa and clang support llvm8, so the repository packages were recompiled and now depend on llvm8. Other packages such as rust still require llvm7, so their dependencies get updated to llvm7. None of these packages can get updated unless you update the llvm dependency of python-llvmlite to llvm7. If a user does not want to install llvm8 and llvm7 in parallel, they can still opt to manually modify this package build and delay the update of any other llvm-related package.

Cbhihe commented on 2019-03-31 15:49

Upgrading to llvm v8.0.0-1 broke python-llvmlite and as a consequence python-numba.

Judging by @mschu's 2018-10-02_12:36 comments below. Can someone confirm that the cop-out is to either revert to extra/llvm7 (currently at v7.0.1-1) from v8.0.0-1 or wait for llvm upgrades until python-llvmlite and python-numba have caught up ?

EvilxFish commented on 2019-03-31 13:02

The package wants llvm < 7.1.0 but llvm is now 8.0.0, Attempting to install with yay gives the following error:

==> Error: Could not find all required packages: llvm<7.1.0 (Wanted by: python-llvmlite)

op3 commented on 2019-01-23 16:08

@jeancf: The hash of v0.27.0.tar.gz changed, make sure to delete the old file and start with a clean build directory.

jeancf commented on 2019-01-10 08:29

Trying to upgrade to 0.27.0-2:

==> Validating source files with sha256sums... v0.27.0.tar.gz ... FAILED ==> ERROR: One or more files did not pass the validity check!