Package Details: python-llvmlite 0.28.0-2

Git Clone URL: https://aur.archlinux.org/python-llvmlite.git (read-only)
Package Base: python-llvmlite
Description: Lightweight LLVM python binding for writing JIT compilers
Upstream URL: https://github.com/numba/llvmlite
Licenses: BSD
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 21
Popularity: 0.404195
First Submitted: 2014-12-29 17:23
Last Updated: 2019-04-01 10:14

Pinned Comments

mschu commented on 2019-05-21 09:47

Until 0.29.0 is out, you need 'python-llvmlite-git' to make it work with current llvm=7.1.0

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

mschu commented on 2017-10-03 08:22

@bartus llvmlite=0.21.0.dev supports llvm>=5, try python-llvmlite-git?

mschu commented on 2017-10-01 09:42

> Why not creating a package for llvm4 on AUR and update dependencies of `python-llvmlite` package to point there.

Patches welcome.

However, the llvmlite situation repeats itself every couple of months and if you don't give me a reason why you *need* llvm5 as soon as it comes out I'm not willing to continuously provide different workarounds.

Also, please don't mis-quote, I said "easiest solution". Give me a reason why you need another one.

bartus commented on 2017-10-01 09:07

@mschu: ''solution is to not update LLVM until the llvmlite catches up.''
Why not creating a package for llvm4 on AUR and update dependencies of `python-llvmlite` package to point there. You would be able to build `python-llvmlite` in chroot with llvm4 and install it alongside llvm5 with split llvm4-libs.
//this is what I basically did on my system, but instead of building llvm4 form source just repackage llvm-libs-4.0.1 from `downgrader` to contain only `/usr/lib/libLLVM.so.4*`.

mschu commented on 2017-09-17 14:21

I updated to llvmlite=0.20.0, which still depends on LLVM<5. If you don't need LLVM=5 and want to use llvmlite, the easiest solution is to not update LLVM until the llvmlite catches up.

j605 commented on 2017-09-17 09:23

The latest llvm update breaks this package since it requires llvm < 4.1. I checked the upstream repo but I am not sure they have updated the package to support llvm 5 but either case we need a llvm4 package or wait for the upstream to update.

mschu commented on 2017-05-24 22:32

Release seems to have changed, updated pkgrel and md5sum.

MeV commented on 2017-05-24 22:26

md5sum is invalid, correct one is b3d0266caa0b9f209f6d93d0ec641d00

tmmsartor commented on 2017-02-16 16:33

@JohnRobson consider using python-llvmlite-bin which ship the also the proper version of llvm.

JohnRobson commented on 2016-06-20 05:20

"error: target not found: llvm<3.8.0" Please, what I need to do?

(I'm using: https://www.archlinux.org/packages/extra/x86_64/llvm/)

jleahy commented on 2016-06-11 11:04

Now llvm has been updated to 3.8 this no longer builds.

It can be fixed by changing the dependency to llvm37-split, add adding "export LLVM_CONFIG=/usr/lib/llvm-3.7/bin/llvm-config" in the build() section.

Also llvm is only a make dependency, it can be removed once the package is built (as it links statically against llvm).

Also the -lLLVMOProfileJIT hack is no longer required for 0.11.