Package Details: python-llvmlite 0.30.0-1

Git Clone URL: https://aur.archlinux.org/python-llvmlite.git (read-only)
Package Base: python-llvmlite
Description: Lightweight LLVM python binding for writing JIT compilers
Upstream URL: https://github.com/numba/llvmlite
Licenses: BSD
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 24
Popularity: 1.55
First Submitted: 2014-12-29 17:23
Last Updated: 2019-10-11 08:41

Pinned Comments

mschu commented on 2019-10-27 15:03

Can anyone confirm if numba works for them with llvmlite patched like below?

I did a clean build for llvmlite+numba and "from numba import jit" gives an llvm error.

For now, the only workaround seems to not update & add in /etc/pacman.conf IgnorePkg = llvm llvm-libs

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

mschu commented on 2018-03-23 15:45

Now it has reached my mirror as well. Updated!

bartus commented on 2018-03-23 09:18

For me, it's already there ;)

pacsearch llvm.*-libs: extra/llvm-libs 6.0.0-4 [installed], extra/llvm35-libs 3.5.2-4 [installed], local/llvm50-libs 5.0.0-2 [installed]

mschu commented on 2018-03-23 08:30

llvm in extra is still 5.0.1, so I'll stick with that until extra upgrades to 6.0.0

If you realize this happens before me please flag it!

bartus commented on 2018-03-23 08:07

@maschu: Would you consider updating deps: depends:llvm50-libs makekdepends:llvm50 Until a new version adopts llvm6 ;)

tigerlee commented on 2018-02-21 01:57

@mschu md5sum doesn't check out, maybe 4b3478517681c94c783867baad58c3db?

mschu commented on 2017-10-03 08:22

@bartus llvmlite=0.21.0.dev supports llvm>=5, try python-llvmlite-git?

mschu commented on 2017-10-01 09:42

> Why not creating a package for llvm4 on AUR and update dependencies of `python-llvmlite` package to point there.

Patches welcome.

However, the llvmlite situation repeats itself every couple of months and if you don't give me a reason why you *need* llvm5 as soon as it comes out I'm not willing to continuously provide different workarounds.

Also, please don't mis-quote, I said "easiest solution". Give me a reason why you need another one.

bartus commented on 2017-10-01 09:07

@mschu: ''solution is to not update LLVM until the llvmlite catches up.''
Why not creating a package for llvm4 on AUR and update dependencies of `python-llvmlite` package to point there. You would be able to build `python-llvmlite` in chroot with llvm4 and install it alongside llvm5 with split llvm4-libs.
//this is what I basically did on my system, but instead of building llvm4 form source just repackage llvm-libs-4.0.1 from `downgrader` to contain only `/usr/lib/libLLVM.so.4*`.

mschu commented on 2017-09-17 14:21

I updated to llvmlite=0.20.0, which still depends on LLVM<5. If you don't need LLVM=5 and want to use llvmlite, the easiest solution is to not update LLVM until the llvmlite catches up.

j605 commented on 2017-09-17 09:23

The latest llvm update breaks this package since it requires llvm < 4.1. I checked the upstream repo but I am not sure they have updated the package to support llvm 5 but either case we need a llvm4 package or wait for the upstream to update.