Package Details: python-llvmlite 0.30.0-1

Git Clone URL: https://aur.archlinux.org/python-llvmlite.git (read-only)
Package Base: python-llvmlite
Description: Lightweight LLVM python binding for writing JIT compilers
Upstream URL: https://github.com/numba/llvmlite
Licenses: BSD
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 23
Popularity: 0.58
First Submitted: 2014-12-29 17:23
Last Updated: 2019-10-11 08:41

Pinned Comments

mschu commented on 2019-10-27 15:03

Can anyone confirm if numba works for them with llvmlite patched like below?

I did a clean build for llvmlite+numba and "from numba import jit" gives an llvm error.

For now, the only workaround seems to not update & add in /etc/pacman.conf IgnorePkg = llvm llvm-libs

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

mschu commented on 2017-05-24 22:32

Release seems to have changed, updated pkgrel and md5sum.

MeV commented on 2017-05-24 22:26

md5sum is invalid, correct one is b3d0266caa0b9f209f6d93d0ec641d00

tmmsartor commented on 2017-02-16 16:33

@JohnRobson consider using python-llvmlite-bin which ship the also the proper version of llvm.

JohnRobson commented on 2016-06-20 05:20

"error: target not found: llvm<3.8.0" Please, what I need to do?

(I'm using: https://www.archlinux.org/packages/extra/x86_64/llvm/)

jleahy commented on 2016-06-11 11:04

Now llvm has been updated to 3.8 this no longer builds.

It can be fixed by changing the dependency to llvm37-split, add adding "export LLVM_CONFIG=/usr/lib/llvm-3.7/bin/llvm-config" in the build() section.

Also llvm is only a make dependency, it can be removed once the package is built (as it links statically against llvm).

Also the -lLLVMOProfileJIT hack is no longer required for 0.11.

mschu commented on 2016-03-01 20:46

0.9.0 now working with llvm-3.7.x

mabl commented on 2015-11-30 21:07

At least there is a pull request:

https://github.com/numba/llvmlite/pull/100

Doesn't build for me though (pip install git+https://github.com/pitrou/llvmlite.git@llvm3.7)

mschu commented on 2015-10-04 20:48

I have updated the dependency to include llvm<3.7 and bumped the release number to 2 until this gets fixed.

lipe_cantarelli commented on 2015-10-04 20:09

It seems to have a compatibility issue with newer versions of llvm: https://github.com/numba/llvmlite/issues/85

It seems to work with llvm-3.6.2-4 though.

mschu commented on 2015-10-02 11:59

Which version of llvm are you using? - I assume it's 0.7.0. Can you try downgrading to 0.6.x and see if this fixes it?