Package Details: python-ly-git 0.9.5.r1.g1cd3260-2

Git Clone URL: https://aur.archlinux.org/python-ly-git.git (read-only)
Package Base: python-ly-git
Description: Python modules to parse, manipulate or create documents in LilyPond format.
Upstream URL: https://github.com/wbsoft/python-ly
Licenses: GPL
Conflicts: python-ly
Provides: python-ly=0.9.5.r1.g1cd3260-2
Submitter: rdoursenaud
Maintainer: rdoursenaud
Last Packager: rdoursenaud
Votes: 1
Popularity: 0.000000
First Submitted: 2015-03-10 07:34
Last Updated: 2017-02-21 15:15

Dependencies (2)

Required by (2)

Sources (1)

Latest Comments

dreieck commented on 2018-09-03 12:11

Should conflict with the package ly-git (and ly), as both install the file /usr/bin/ly. (ly is a display manager and has nothing to do with LilyPond.)

rdoursenaud commented on 2017-02-21 15:17

@archmylinux Sorry, I mislabeled the versions indeed.
This took me quite some time to figure out I also had to version the provides variable but everything should be sorted out now. Thanks for the report!

archmylinux commented on 2017-02-20 15:48

So the "frescobaldi-git" packages requires "python-ly>=0.9.5" and this package provides "pkgver=v0.9.5.r1.g1cd3260"

Having successfully installed "python-ly-git", "frescobaldi-git" still complains about missing dependency -> "python-ly>=0.9.5"

Is it because v0.9.5.r1.g1cd3260 is not >= to 0.9.5 ?

I foolishly tried editing the pkgver field in the PKGBUILD to no avail.

What I am missing here?

archmylinux commented on 2017-02-03 16:26

Thought this might be of interest,

When I install frescobaldi and python-ly (not python-ly-git) *and then* install python-ly-git I get the following conflict.

:: python-ly-git and python-ly are in conflict. Remove python-ly? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: frescobaldi-git: removing python-ly breaks dependency 'python-ly>=0.9.4'