Package Details: python-matplotlib-noqt 1.5.0-2

Git Clone URL: https://aur.archlinux.org/python-matplotlib-noqt.git (read-only)
Package Base: python-matplotlib-noqt
Description: A python plotting library, making publication quality plots
Upstream URL: http://matplotlib.org
Licenses: custom
Submitter: pedromj
Maintainer: pedromj
Last Packager: pedromj
Votes: 2
Popularity: 0.000000
First Submitted: 2013-01-03 14:07
Last Updated: 2015-12-10 09:07

Dependencies (22)

Required by (0)

Sources (1)

Latest Comments

redshoe commented on 2016-02-12 01:26

I can't build the package. The error message is as follows.

================================================================

==> Starting prepare()...
==> Starting build()...
Downloading http://pypi.python.org/packages/source/d/distribute/distribute-0.6.28.tar.gz
Extracting in /tmp/tmp_izirtab
Traceback (most recent call last):
File "/tmp/yaourt-tmp-rangke/aur-python-matplotlib-noqt/src/matplotlib-1.5.0-py3/distribute_setup.py", line 147, in use_setuptools
import pkg_resources
ImportError: No module named 'pkg_resources'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "setup.py", line 10, in <module>
use_setuptools()
File "/tmp/yaourt-tmp-rangke/aur-python-matplotlib-noqt/src/matplotlib-1.5.0-py3/distribute_setup.py", line 163, in use_setuptools
return _do_download(version, download_base, to_dir, download_delay)
File "/tmp/yaourt-tmp-rangke/aur-python-matplotlib-noqt/src/matplotlib-1.5.0-py3/distribute_setup.py", line 133, in _do_download
_build_egg(egg, tarball, to_dir)
File "/tmp/yaourt-tmp-rangke/aur-python-matplotlib-noqt/src/matplotlib-1.5.0-py3/distribute_setup.py", line 106, in _build_egg
_extractall(tar)
File "/tmp/yaourt-tmp-rangke/aur-python-matplotlib-noqt/src/matplotlib-1.5.0-py3/distribute_setup.py", line 511, in _extractall
self.chown(tarinfo, dirpath)
TypeError: chown() missing 1 required positional argument: 'numeric_owner'
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build python-matplotlib-noqt.
==> Restart building python-matplotlib-noqt ? [y/N]

pedromj commented on 2014-10-23 11:10

Hi,

I have updated and fixed the stated problems in the PKGBUILD. Please check them and test it. Thank you.

Regards,
Pedro

pedromj commented on 2014-10-23 11:04

Updated, please test.

TrialnError commented on 2014-06-08 19:27

And one more:

python-gobject is not just a makedep. Maybe it should be additionally added as optdep?
Without it python complains, as it defaults to the GTK3 backend

$ python -c "import matplotlib.pyplot"
Traceback (most recent call last):
File "/usr/lib/python3.4/site-packages/matplotlib/backends/backend_gtk3.py", line 7, in <module>
import gi
ImportError: No module named 'gi'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/usr/lib/python3.4/site-packages/matplotlib/pyplot.py", line 98, in <module>
_backend_mod, new_figure_manager, draw_if_interactive, _show = pylab_setup()
File "/usr/lib/python3.4/site-packages/matplotlib/backends/__init__.py", line 28, in pylab_setup
globals(),locals(),[backend_name],0)
File "/usr/lib/python3.4/site-packages/matplotlib/backends/backend_gtk3cairo.py", line 1, in <module>
from . import backend_gtk3
File "/usr/lib/python3.4/site-packages/matplotlib/backends/backend_gtk3.py", line 9, in <module>
raise ImportError("Gtk3 backend requires pygobject to be installed.")
ImportError: Gtk3 backend requires pygobject to be installed.

TrialnError commented on 2014-06-06 15:08

A few things about this PKGBuild and the one for python2.

Is there a specific reason why there is no conflicts/provides entry in the PKGBuild to conflict the package from repo?

And secondly. The Guidelines suggest, that every code, that changes the code should be in the extra function prepare()[0].
Which means the part which changes the shebang of the files should be in prepare().
______
[0]https://wiki.archlinux.org/index.php/Creating_packages#PKGBUILD_Functions

pedromj commented on 2014-04-06 19:31

New package, please test.

pedromj commented on 2013-08-21 10:06

Updated, please test. Thank you.