Package Details: python-mpd2 0.5.5-1

Git Clone URL: https://aur.archlinux.org/python-mpd2.git (read-only)
Package Base: python-mpd2
Description: Python MPD client library
Upstream URL: http://pypi.python.org/pypi/python-mpd2
Licenses: GPL3
Submitter: linkmauve
Maintainer: Mic92
Last Packager: Mic92
Votes: 27
Popularity: 0.151424
First Submitted: 2012-05-14 17:44
Last Updated: 2016-04-24 12:45

Dependencies (2)

Required by (6)

Sources (1)

Latest Comments

Mic92 commented on 2016-04-24 12:49

updated SRCINFO as well

steelcowboy commented on 2015-10-02 05:21

Please do something just so AUR helpers will be signalled to reinstall, as it needs to be reinstalled under Python 3.5 to continue using it

Mic92 commented on 2014-12-08 16:23

Update checksum without bump a release

The_Nut commented on 2014-12-06 19:07

You forgot to update the checksums.
Here are the new ones:

md5:d891c3313011dbc6b294c2abf8b87da6
sha1:af0b2a837603a9eb9a06217e262a08222fc4b40e
sha256:1cc8f404652a069b3ef2c11de9a8893863be291dc4af5c792eeab0ab06e80ec1

Mic92 commented on 2013-01-25 21:08

As there is a python2-mpd2 package, please use this instead of python-mpd2, if you want the python2 version.

I informed the maintainer to add to add a conflict with python-mpd2

hokasch commented on 2013-01-25 17:14

The python2-mpd2 package should conflict with/provide "python2-mpd" instead of "python-mpd".

supermihi commented on 2013-01-14 08:20

0.5.0 is out

disastro commented on 2012-12-15 00:34

0.4.6 out, and could you change the python setup.py command to python3 setup.py like I described previously?

disastro commented on 2012-12-07 06:08

I think you got me wrong :)

I meant to change
python setup.py install --root="$pkgdir/" --optimize=1
to be
python3 setup.py install --root="$pkgdir/" --optimize=1
since the python can also point to python2 on some systems, like mine.

All packages in the official repos are working like this so you can freely point "python" to either 2 or 3 on your system.

Mic92 commented on 2012-12-05 16:29

python-mpd v0.4.5 is out :)

linkmauve commented on 2012-12-05 10:30

It is the policy of ArchLinux to name python2 packages python2-*, and python3 packages python-*. I don’t like that convention, I would like python2-* and python3-* better, but I’m not in a position to juge that.
Here are the official guidelines: https://wiki.archlinux.org/index.php/Python_Package_Guidelines#Package_Naming

Softwares not yet updated to work on python3 should depend on the python2-* versions of python packages.

disastro commented on 2012-12-05 07:09

Could you change package_python-mpd2() to use "python3" instead of "python" to fix errors when "python" points to "python2" instead? Thank you :)