Package Details: python-nbdime 1.0.5-1

Git Clone URL: https://aur.archlinux.org/python-nbdime.git (read-only)
Package Base: python-nbdime
Description: Diff and merge of Jupyter Notebooks
Upstream URL: http://jupyter.org
Keywords: diff git jupyter notebook
Licenses: BSD
Submitter: Perfi
Maintainer: j605
Last Packager: j605
Votes: 1
Popularity: 0.000000
First Submitted: 2017-03-19 18:52
Last Updated: 2019-05-11 16:55

Latest Comments

lobachevsky commented on 2017-11-08 15:23

The proper dependency for this package is rather

depends = depends=('python' 'python-six' 'python-gitpython' 'python-tornado' 'jupyter-nbformat' 'python-colorama')
makedepends=('python-setuptools' 'npm')

ganileni commented on 2017-11-01 12:08

if you install it with eg

$pacaur -S python-nbdime

and then run it, it will throw an error:

$nbdime
pkg_resources.DistributionNotFound: The 'GitPython' distribution was not found and is required by nbdime

this is because it depends on other python modules that are luckily for us on the AUR. The packages are:

python-gitpython python-tornado jupyter-nbformat

so if you add the dependencies to the PKGBUILD it should solve the problem.