Package Details: python-nikola-git 7.7.9.r3.g43d3c51-1

Git Clone URL: https://aur.archlinux.org/python-nikola-git.git (read-only)
Package Base: python-nikola-git
Description: A modular, fast, simple, static website generator. (git version)
Upstream URL: https://getnikola.com/
Licenses: MIT
Conflicts: python-nikola
Submitter: Kwpolska
Maintainer: Kwpolska
Last Packager: Kwpolska
Votes: 7
Popularity: 0.839487
First Submitted: 2013-01-28 11:23
Last Updated: 2016-06-11 10:33

Dependencies (48)

Required by (0)

Sources (1)

Latest Comments

HalosGhost commented on 2014-04-07 21:35

Thank you!

All the best,

HalosGhost commented on 2014-04-06 23:53

Kwpolska, it seems that you may have forgotten to rebuild the package (with makepkg -s) before building the source package (e.g., with makepkg -S). This doesn't cause any issue with building packages from your PKGBUILD, but it does mean that the versions generated by the pkgver look something like this:
v6.4.0.r519.g532f2bc

However, the AUR reads this version as being lower than the one specified by your current PKGBUILD (i.e., 6.4.0-1). As a result, anyone using an AUR helper will get a notification that their package is out-of-date even if they are perfectly up-to-date. I know it's a minor issue, but if you wouldn't mind rebuilding the package so the pkgver in your PKGBUILD is up-to-date, that would be very nice :)

All the best,

Kwpolska commented on 2014-01-07 19:24

@anatolik: done. Nobody has notified about a standards change.

anatolik commented on 2014-01-07 19:21

It is better if 'version' use 'r' as a git revision separator. https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines#Git

carstene1ns commented on 2013-11-15 21:24

It is good practice to include a conflicts=('python2-nikola') and provides=('python2-nikola').

Kwpolska commented on 2013-03-02 09:39

I am aware! Fixing it right away.

essenceoffoo commented on 2013-03-02 09:25

Missing dependency: python-pytz (from community)