Package Details: python-nikola 7.8.1-2

Git Clone URL: https://aur.archlinux.org/python-nikola.git (read-only)
Package Base: python-nikola
Description: A modular, fast, simple, static website generator.
Upstream URL: https://getnikola.com/
Keywords: nikola python static website
Licenses: MIT
Conflicts: python-nikola-git
Submitter: Kwpolska
Maintainer: Kwpolska
Last Packager: Kwpolska
Votes: 15
Popularity: 0.262445
First Submitted: 2013-01-28 11:23
Last Updated: 2016-10-14 07:15

Dependencies (49)

Required by (0)

Sources (1)

Latest Comments

Kwpolska commented on 2016-10-14 07:18

@hiliev

Oh, sorry. I sometimes wish things were less case-sensitive. Fixed in 7.8.1-2.

hiliev commented on 2016-10-13 22:22

Hi! The PKGBUILD is broken. The name of the directory in the archive is Nikola-7.8.1 while the PKGBUILD tries to cd into ${_pyname}-${pkgver}, which expands to nikola-7.8.1. Replacing ${_pyname} with ${_pynameweb} on lines 23, 46, and 56 fixes the problem.

hiliev commented on 2016-07-23 16:02

It seems that currently Nikola requires python-piexif 1.0.4 while the latest AUR package provides 1.0.3. One should manually download the PKGBUILD for python-piexif and then correct the version and the SHA512 sum until the package gets updated.

Kwpolska commented on 2015-10-28 16:30

@mhwllwig You can just change the makedepends and ask makepkg to build only the Python 3 version.

mhellwig commented on 2015-10-27 20:12

ssso... I can't use this to just build the python3 version of this program?

Kwpolska commented on 2015-10-27 20:06

@mhellwig Because makepkg won’t install/build the dependencies otherwise, as this is a split package.

mhellwig commented on 2015-10-27 19:45

I am somewhat confused. Why does the PKGBUILD have makedepends on the python- as well as python2- versions of a number of programs?

Kwpolska commented on 2015-06-10 15:12

@tuxitop Fortunately, I’m the maintainer of both, so I can just downgrade yapsy and change the dependency here — done.

tuxitop commented on 2015-06-09 21:06

yapsy should be version 1.10.423 as mentioned in requirements.txt, It doesn't work with version 1.11.123 in aur.

shmilee commented on 2015-05-17 19:21

please add optdepends array, for optional features `requirements-extras.txt`.

All comments