Package Details: python-numba 0.55.0dev0-1

Git Clone URL: (read-only, click to copy)
Package Base: python-numba
Description: NumPy aware dynamic Python compiler using LLVM
Upstream URL:
Licenses: BSD
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 42
Popularity: 0.68
First Submitted: 2014-05-10 20:33
Last Updated: 2021-10-09 20:33

Latest Comments

1 2 3 4 5 Next › Last »

pirofti commented on 2021-09-28 09:00

SHA changed: ac2b45622a0642970302e8102947f391cc9ebe3e9591a80fb3769e7cb7f7ed2a

szsdk commented on 2021-09-03 06:53

According to github of numba, the numpy should be <1.21.

jlaehne commented on 2021-09-02 07:26

The very strict llvmlite dependency makes updating very tedious each time, as it prevents an llvmlite update, which in turn prevents the numba update.

szsdk commented on 2021-08-31 23:59

Now python-llvmlite is already updated to 0.37. But this package is still limited to python-llvmlite<0.37.

vuvko commented on 2021-02-27 09:52

I think the hash sum is wrong for the latest version. Mine is 9d07ec01fbdba0280bfcebab44fda5d364870f161263b93828651febec061ceb

bartus commented on 2021-02-09 16:46

Need some fix, mainly pkgsums and python-setuptools missing in makedepends


merge with git am -s < <(curl -s

petronny commented on 2021-01-28 08:42

According to this comment, we can just apply the Python 3.9 compatibility patch to 0.52.0 with a bit of patch fuzz and a llvmlite version conflict in

All the numba unit tests should pass on x86_64 .

Only some tests fail on armhf.

I think we can apply the patch now instead of waiting for 0.53RC1

bcb commented on 2021-01-27 18:04

@jackjackk see the pinned comments -- Python 3.9 is not currently supported by the release version of numba. Try the python-numba-py39-git package instead which works for me (you might also need to use python-llvmlite-git)

jackjackk commented on 2021-01-27 17:56


Traceback (most recent call last):
  File "/home/jack/.cache/yay/python-numba/src/numba-0.52.0/", line 50, in <module>
  File "/home/jack/.cache/yay/python-numba/src/numba-0.52.0/", line 47, in _guard_py_ver
    raise RuntimeError(msg.format(cur_py, min_py, max_py))
RuntimeError: Cannot install on Python version 3.9.1; only versions >=3.6,<3.9 are supported.
==> ERROR: A failure occurred in build().
error making: python-numba

yodaembedding commented on 2021-01-25 08:49

Missing makedepends: python-setuptools.