Package Details: python-numba 0.56.0-1

Git Clone URL: https://aur.archlinux.org/python-numba.git (read-only, click to copy)
Package Base: python-numba
Description: NumPy aware dynamic Python compiler using LLVM
Upstream URL: https://numba.pydata.org/
Licenses: BSD
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 51
Popularity: 1.57
First Submitted: 2014-05-10 20:33 (UTC)
Last Updated: 2022-08-09 11:38 (UTC)

Pinned Comments

mschu commented on 2022-05-26 21:46 (UTC)

This package will track the numba release compatible with llvmlite in <community>. If you want the latest version, use python-numba-git

Latest Comments

lmartinez-mirror commented on 2022-08-18 17:01 (UTC) (edited on 2022-08-18 17:06 (UTC) by lmartinez-mirror)

Is there a reason why this package depends on python-numpy1.22 and not python-numpy proper? I can't find anything explicit in upstream requirements that lists 1.22.

EDIT: Nevermind I see in the setup.py that upstream puts a cap on the runtime versions.

petronny commented on 2022-08-13 03:46 (UTC)

Hi, cython may not be a makedepend according to the discussions in python-numba-git.

a821 commented on 2022-08-10 20:42 (UTC)

@flying-sheep: python-setuptools is a runtime dependency according to numba docs, so it belongs in depends (but the docs could be outdated)

@carlosal1015: You need to resolve your conflicts, the error message is quite clear. It builds fine for me in a clean chroot (though I have not tested the resulting package yet).

carlosal1015 commented on 2022-08-10 19:06 (UTC)

Hi, I have the following message error:

==> Making package: python-numba 0.56.0-1 (Wed Aug 10 14:02:49 2022)
==> Retrieving sources...
  -> Found numba-0.56.0.tar.gz
==> Validating source files with sha256sums...
    numba-0.56.0.tar.gz ... Passed
 -> python-setuptools not satisfied, flushing install queue
==> Making package: python-numpy1.22 1.22.4-1 (Wed Aug 10 14:02:50 2022)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found numpy-1.22.4.tar.gz
==> Validating source files with sha512sums...
    numpy-1.22.4.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting numpy-1.22.4.tar.gz with bsdtar
==> Sources are ready.
==> Making package: python-numpy1.22 1.22.4-1 (Wed Aug 10 14:02:52 2022)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Sources are ready.
 -> python-numpy1.22-1.22.4-1 already made -- skipping build
 -> python-numpy1.22 not satisfied, flushing install queue
loading packages...
resolving dependencies...
looking for conflicting packages...
:: python-numpy1.22 and python-numpy are in conflict. Remove python-numpy? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing python-numpy breaks dependency 'python-numpy>=1.7' required by python-datashape
checking dependencies...

I am agree with @flying-sheep and @petronny, python-pip, in the official repositories, it is often used as makedependency, but I think we can avoid here.

flying-sheep commented on 2022-08-10 09:42 (UTC)

python-pip has no place in makedepends or depends and python-setuptools belongs into makedepends.

And 0.56 still caps the numpy version: https://github.com/numba/numba/blob/0.56.0/setup.py

petronny commented on 2022-08-09 15:33 (UTC)

This package can be built against python-numpy in the official repo after adding python-pip to makedepends.

And python-setuptools could be also removed from depends.

dront78 commented on 2022-08-09 06:37 (UTC)

llvmlite 0.39 is out

mschu commented on 2022-07-25 22:15 (UTC) (edited on 2022-07-27 16:50 (UTC) by mschu)

Release 0.56.0 is out, but latest commit explicitly requires numpy<1.23 and llvmlite>=0.39.0.

So we'll use @tallero's python-numpy1.22 and wait for llvmlite in <community> (also out, just the package needs to be updated)

tallero commented on 2022-07-23 09:57 (UTC) (edited on 2022-07-23 09:57 (UTC) by tallero)

@carlosal1015, @mschu: I have uploaded python-numpy1.22.

If we have to stick with current version for a while it may be useful to add it as python-numba dependency.

carlosal1015 commented on 2022-07-22 18:19 (UTC)

The version 0.56 enable python-numpy-1.23.0, it can be used.

SpotlightKid commented on 2022-07-22 18:09 (UTC)

python-numpy in the extra repo is now at 1.23.0, which breaks numba:

>>> import numba
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python3.10/site-packages/numba/__init__.py", line 200, in <module>
    _ensure_critical_deps()
  File "/usr/lib/python3.10/site-packages/numba/__init__.py", line 140, in _ensure_critical_deps
    raise ImportError("Numba needs NumPy 1.22 or less")
ImportError: Numba needs NumPy 1.22 or less

snowball commented on 2022-06-02 19:56 (UTC)

The SHA256 hash changed even though the version is the same. Here are the differences:

$ sha256sum numba-0.55.1-old.tar.gz numba-0.55.1-new.tar.gz 
542a9b514031f6afae971b627930fcaec057cdb604d54db7cbddfb050c580fb9  numba-0.55.1-old.tar.gz
578413394c7e6b23df0382857bf0a6752752110500a17adaf4a548d1f7b34626  numba-0.55.1-new.tar.gz
$ tar -C old -xf numba-0.55.1-old.tar.gz
$ tar -C new -xf numba-0.55.1-new.tar.gz
$ diff -r old new
diff --color -r old/numba-0.55.1/numba/_version.py new/numba-0.55.1/numba/_version.py
17c17
< git_refnames = " (tag: 0.55.1, release0.55)"
---
> git_refnames = " (tag: 0.55.1)"

Nothing to be concerned about, but it's annoying that they didn't give it a new version number.

flying-sheep commented on 2022-06-02 13:18 (UTC)

Can you please fix this package?

iyanmv commented on 2022-05-27 14:34 (UTC)

Why did the hash changed from upstream for the same version? Anyone knows... that's weird.

iyanmv commented on 2022-05-27 14:32 (UTC) (edited on 2022-05-27 14:32 (UTC) by iyanmv)

Sorry, didn't notice your pinned comment before flagging the package.

mschu commented on 2022-05-26 21:46 (UTC)

This package will track the numba release compatible with llvmlite in <community>. If you want the latest version, use python-numba-git

dobedobedo commented on 2022-02-28 11:36 (UTC)

Hi, The current version of numba doesn't work with numpy 1.22. The temporary solution I found is to use 0.56.0dev0 from anaconda archive. Here's the PKGBUILD

# Maintainer: Michael Schubert <mschu.dev at gmail> github.com/mschubert/PKGBUILDs
pkgname=python-numba
pkgver=0.56.0dev0
pkgrel=1
pkgdesc="NumPy aware dynamic Python compiler using LLVM"
url="https://numba.pydata.org/"
arch=('i686' 'x86_64')
license=('BSD')
depends=('python-llvmlite' 'python-numpy>=1.17' 'intel-tbb>=2021.1')
makedepends=('cython' 'python-setuptools')
optdepends=('python-scipy>=1.0.0')
source=('https://anaconda.org/numba/numba/0.56.0dev0/download/linux-64/numba-0.56.0dev0-np1.21py3.10ha54aa7d_g53ea89fee_298.tar.bz2')
sha256sums=('17cc396db07ffbdb559f5f2cf027487c764028351f31743c5ad0292f951d871a')

package() {
  cd "$srcdir/lib/python3.10/site-packages"
  mkdir -p "$pkgdir/usr/lib/python3.10/site-packages/"
  cp -r * "$pkgdir/usr/lib/python3.10/site-packages/"
}

In addition, numba 0.56 only works with llvmlite 0.39, so you need to use the dev version of llvmlite as well:

# Maintainer: Yuri Iozzelli <y.iozzelli@gmail.com>
pkgname=python-llvmlite-bin
pkgver=0.39.0dev0
pkgrel=1
epoch=
pkgdesc="A lightweight LLVM python binding for writing JIT compilers"
arch=("x86_64")
url="http://llvmlite.pydata.org"
license=('GPL')
groups=()
depends=("python")
provides=("python-llvmlite=$pkgver")
conflicts=("python-llvmlite")
source=("https://anaconda.org/numba/llvmlite/0.39.0dev0/download/linux-64/llvmlite-0.39.0dev0-py310he1b5a44_42.tar.bz2")

package() {
      cd "$srcdir/lib/python3.10/site-packages"
      mkdir -p "$pkgdir/usr/lib/python3.10/site-packages/"
      cp -r * "$pkgdir/usr/lib/python3.10/site-packages/"
}
md5sums=('7ee98171c8317c1e388cc5711d2e9542')

Hope it helps.

lllf commented on 2022-01-31 14:29 (UTC) (edited on 2022-01-31 14:30 (UTC) by lllf)

Doesn't seem to want to build when python-llvmite-bin is installed, insists on trying to install python-llvmite.

I believe it is because the current version of python-llvmite-bin is 0.38.0rc1.

Focshole commented on 2021-12-27 16:14 (UTC)

I get a build error: Build failed: fatal error: omp.h: No such file or directory

openmp is required at least for building the package.

mschu commented on 2021-12-20 13:03 (UTC)

This is now tracking 0.55.0rc1 for python>=3.10.0 compatibility

pirofti commented on 2021-09-28 09:00 (UTC)

SHA changed: ac2b45622a0642970302e8102947f391cc9ebe3e9591a80fb3769e7cb7f7ed2a

szsdk commented on 2021-09-03 06:53 (UTC) (edited on 2021-09-03 06:53 (UTC) by szsdk)

According to github of numba, the numpy should be <1.21.

jlaehne commented on 2021-09-02 07:26 (UTC)

The very strict llvmlite dependency makes updating very tedious each time, as it prevents an llvmlite update, which in turn prevents the numba update.

szsdk commented on 2021-08-31 23:59 (UTC)

Now python-llvmlite is already updated to 0.37. But this package is still limited to python-llvmlite<0.37.

vuvko commented on 2021-02-27 09:52 (UTC)

I think the hash sum is wrong for the latest version. Mine is 9d07ec01fbdba0280bfcebab44fda5d364870f161263b93828651febec061ceb

bartus commented on 2021-02-09 16:46 (UTC)

Need some fix, mainly pkgsums and python-setuptools missing in makedepends

[patch]

merge with git am -s < <(curl -s http://ix.io/2ORe)

petronny commented on 2021-01-28 08:42 (UTC) (edited on 2021-01-28 08:44 (UTC) by petronny)

According to this comment, we can just apply the Python 3.9 compatibility patch to 0.52.0 with a bit of patch fuzz and a llvmlite version conflict in setup.py.

All the numba unit tests should pass on x86_64 .

Only some tests fail on armhf.

I think we can apply the patch now instead of waiting for 0.53RC1

bcb commented on 2021-01-27 18:04 (UTC)

@jackjackk see the pinned comments -- Python 3.9 is not currently supported by the release version of numba. Try the python-numba-py39-git package instead which works for me (you might also need to use python-llvmlite-git)

jackjackk commented on 2021-01-27 17:56 (UTC)

Getting

Traceback (most recent call last):
  File "/home/jack/.cache/yay/python-numba/src/numba-0.52.0/setup.py", line 50, in <module>
    _guard_py_ver()
  File "/home/jack/.cache/yay/python-numba/src/numba-0.52.0/setup.py", line 47, in _guard_py_ver
    raise RuntimeError(msg.format(cur_py, min_py, max_py))
RuntimeError: Cannot install on Python version 3.9.1; only versions >=3.6,<3.9 are supported.
==> ERROR: A failure occurred in build().
    Aborting...
error making: python-numba

yodaembedding commented on 2021-01-25 08:49 (UTC) (edited on 2021-02-07 12:22 (UTC) by yodaembedding)

Missing makedepends: python-setuptools.

gboehl commented on 2020-12-15 17:32 (UTC)

Note that the update has been postponed to land in 0.53, which is tagged for RC in "early 2021". Probably it is a good idea to look into the git version in the meanwhile...

bcb commented on 2020-12-02 11:12 (UTC)

Note that Python 3.9 is not fully supported due to bytecode changes, some code might work and other code fail. A 0.52.1 update is planned for "mid-December or before" with Python 3.9 support -- see https://github.com/numba/numba/issues/6345

a821 commented on 2020-09-03 07:54 (UTC)

sha256sums=('249f3b9cc3ceff0f18e328cf6c132b5eaed92c3c1c840d1fbd0823f4dbf7a126')

Kihra1 commented on 2020-09-02 18:21 (UTC)

==> Validating source files with sha256sums... numba-0.51.1.tar.gz ... FAILED

jlaehne commented on 2020-08-18 15:48 (UTC)

Your llvmlite<... dependencies introduce circular dependency issues on upgrade. The old numba requires llmvmlite<0.34.0, therefore llvmlite is not upgraded, while the upgrade is necessary to upgrade numba. Always have to force the upgrades with yay - can't you drop the llvmlite<0.35 dependency, or what is the motivation behind?

renordw commented on 2020-06-24 18:18 (UTC)

0.50.0 corresponds to:

sha256sums=('56d05be883c3ce978acf5ae4d513193bef826138f46737211f140ff6b026634a')

andalenavals commented on 2020-05-04 06:41 (UTC)

sha256sums=('b9b764785e91cafb6453f37349753a30f3f8e98c684b763449feedd0663463e7')

n8henrie commented on 2019-12-10 17:12 (UTC)

sha256 for 0.46 is incorrect

bcb commented on 2019-10-22 07:48 (UTC)

Dependency on python-llvmlite should be >= 0.30.0:

ImportError: Numba requires at least version 0.30.0 of llvmlite.
Installed version is 0.28.0.
Please update llvmlite.

bogeyman2007 commented on 2019-06-23 04:35 (UTC)

Hi,

Does anyone got the following error from numba when using LLVM 8?


Traceback (most recent call last):
  File "fast_functions.py", line 6, in <module>
    import numba
  File "/usr/lib/python3.7/site-packages/numba/__init__.py", line 11, in <module>
    from . import config, errors, _runtests as runtests, types
  File "/usr/lib/python3.7/site-packages/numba/config.py", line 18, in <module>
    import llvmlite.binding as ll
  File "/usr/lib/python3.7/site-packages/llvmlite/binding/__init__.py", line 6, in <module>
    from .dylib import *
  File "/usr/lib/python3.7/site-packages/llvmlite/binding/dylib.py", line 4, in <module>
    from . import ffi
  File "/usr/lib/python3.7/site-packages/llvmlite/binding/ffi.py", line 154, in <module>
    raise OSError("Could not load shared object file: {}".format(_lib_name))
OSError: Could not load shared object file: libllvmlite.so

This error is gone when I switch back to LLVM 7.

Maverick commented on 2019-03-23 23:47 (UTC) (edited on 2019-03-23 23:48 (UTC) by Maverick)

Could you please update the dependency to 'llvmlite>=0.28.0'? Otherwise it won't run and won't update llvmlite during install.

I've made a package 'python-numba-roctools-git' to support AMD ROCm target in numba. Normally you can only install it with conda and it carries a statically linked LLVM6. I've patched it in the AUR to use arch's current LLVM with dynamic linking - it passes the tests and all, but the triple name has changed: it is "amdgcn-amd-amdhsa" now rather then "amdgcn--amdhsa". It needs to be changed under site-packages/numba/roc/hlc/__init__.py , otherwise there are warnings during compile (still works). Could you integrate the patch? I think whoever would use the unpatched conda version would run anaconda and not AUR package anyway, so there should not be an issue.

goduck777 commented on 2018-10-15 17:46 (UTC)

The sha256sums for 0.40.0 package is incorrect. Please fix it.

petronny commented on 2018-06-22 03:51 (UTC)

Please merge python-numba and python2-numba into one PKGBUILD. For example: https://aur.archlinux.org/packages/python-librosa

yodaembedding commented on 2018-05-21 10:05 (UTC)

Latest MD5 is c70b3c4a2477ce85571aedd24f9b84c2

mschu commented on 2018-04-05 11:05 (UTC)

Thank you, fixed now.

flying-sheep commented on 2018-04-05 10:17 (UTC)

there‘s a superfluous comma in .SRCINFO which makes it impossible to install this

zsrkmyn commented on 2017-12-23 17:52 (UTC)

python-numpy is needed as depends.

mschu commented on 2017-12-17 14:14 (UTC)

Updated & release bumped (checksum changed)

renato_garcia commented on 2017-07-25 17:37 (UTC)

I think that the md5sum on PKGBUILD is wrong. The correct one is md5sums=('00b8fbe8c9c1d2dc83cdd5a529072a98')

axil commented on 2016-12-02 08:10 (UTC)

I've installed llvm-3.8.1-1 from arch archive (and the corresponding llvm-libs). After that this python-numba package installs and works fine.

commented on 2016-03-27 12:31 (UTC)

MD5 sums check doesn't pass.

mschu commented on 2016-03-01 22:32 (UTC)

Thanks for the comment, I added the version requirement to the PKGBUILD.

lonaowna commented on 2016-03-01 20:59 (UTC)

python-numba is currently broken in combination with the latest python-llvmlite 0.9.0 This will be fixed any moment with Numba 0.24.[1] [1] https://github.com/numba/numba/issues/1729

mschu commented on 2016-02-19 14:31 (UTC)

For LLVM 3.7 support, use python-llvmlite-git until 0.9.0 stable is released.

lonaowna commented on 2016-02-19 12:28 (UTC)

FYI: Numba works with LLVM 3.7 + python-llvmlite-git + python-numba-git

mschu commented on 2016-02-14 20:41 (UTC)

You need to recompile python-llvmlite. Unfortunately, PKGBUILDs don't support that "recompile dependency" flag.

c3real-killer commented on 2016-02-13 16:03 (UTC) (edited on 2016-02-13 16:16 (UTC) by c3real-killer)

Just downgraded llvm and llvm-libs to 3.6.2-4, and installed python-numba. Then when importing got: OSError: /usr/lib/python3.5/site-packages/llvmlite/binding/libllvmlite.so: undefined symbol: _ZN4llvm3sys22getDefaultTargetTripleB5cxx11Ev

mschu commented on 2016-02-11 14:29 (UTC)

Have you tried with llvm=3.7.0? If it works, I can add a mask to hard-require it.

c3real-killer commented on 2016-02-11 14:20 (UTC)

It would be safe to downgrade LLVM to 3.7?

mschu commented on 2016-02-11 10:25 (UTC)

The issue here is not numba but python-llvmlite that does not compile because of a missing include/llvm/Targets/TargetLibraryInfo.h. Upgrading to 0.9.0.dev does not solve it. The Arch package for llvm does provide a file with the same name in include/llvm/Analysis/TargetLibraryInfo.h, but they are not compatible (compile error because of missing function definitions). This does not seem to be trivial to fix and I'm limited on time right now. Patches for python-llvmlite welcome.

c3real-killer commented on 2016-02-10 18:43 (UTC)

Cannot be installed with LLVM 3.7.1-1 (current). Any hope that this will be fixed soon?

mschu commented on 2016-01-18 09:48 (UTC)

Updated, thanks.

ayr0 commented on 2015-01-11 04:55 (UTC)

Could you make this installable along side the python2 version? Currently, only the python2 or the python3 version can be installed, but not both.

mschu commented on 2014-08-30 14:56 (UTC)

I'm in the process of updating a couple of packages, including this one. It is not true that this is a duplicate, see the "python" commands for building/installing instead of the "python2". However, the dependencies should be set to python>3 packages as well - thanks for spotting this.

qs9rx commented on 2014-08-30 14:32 (UTC)

This seems to be an outdated duplicate of https://aur.archlinux.org/packages/python2-numba/ , not a python3 version as the name would suggest. Could you please update it to python3 or remove it?